PAT 1038 Recover the Smallest Number

 Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

 Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

 For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
const int Max=1e4+5;
bool Compare(string x,string y)
{
    return x+y<y+x;
}
int main()
{
    int N;
    string str;
    scanf("%d",&N);
    vector<string> v;
    for(int i=0;i<N;i++)
    {
        cin>>str;
        v.push_back(str);
    }
    sort(v.begin(),v.end(),Compare);
    string ans=v[0];
    for(int i=1;i<N;i++)
        ans=ans+v[i];
    int index=0;
    while(ans[index]=='0')
        index+=1;
    if(index>=ans.size())
        cout<<"0";
    else
    {
        for(int i=index;i<ans.size();i++)
            cout<<ans[i];
    }
    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/84778019