(PAT 1038) Recover the Smallest Number(贪心算法)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/alex1997222/article/details/86296536

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

解题思路:

将数字两两之间进行一定的规律进行排序即可,规律:

S1 + S2 < S2 + S1,即根据贪心策略,两个数字拼起来的数字总是最小的

这里直接用cmp函数编写规律,用sort排序即可

代码如下:

#include <algorithm>
#include <iostream>
#include <string>
#include <string.h>
using namespace std;
const int MAXN = 10001;
int Squence[MAXN];
string Numbers[MAXN];

bool cmp(string a, string b) {
	return a + b < b + a;  //string数字间的比较,会自动化成int进行比较
}

int main() {
	int N;
	cin >> N;
	for (int i = 0; i < N; ++i) {
		cin >> Numbers[i];
	}
	sort(Numbers, Numbers + N, cmp);
	string ans;
	for (int i = 0; i < N; ++i) {
		ans += Numbers[i];   //将Numbers里的内容拼接进去
	}
	//抹0操作
	while (ans.size() != 0 && ans[0] == '0') {
		ans.erase(ans.begin());  //抹去开头
	}

	if (ans.size() == 0) {
		cout << 0;
	}
	else {
		cout << ans;
	}

	system("PAUSE");
	return 0;
}

猜你喜欢

转载自blog.csdn.net/alex1997222/article/details/86296536