问题 B: Problem E

题目描述
请写一个程序,判断给定表达式中的括号是否匹配,表达式中的合法括号为”(“, “)”, “[", "]“, “{“, ”}”,这三个括号可以按照任意的次序嵌套使用。

输入
有多个表达式,输入数据的第一行是表达式的数目,每个表达式占一行。

输出
对每个表达式,若其中的括号是匹配的,则输出”yes”,否则输出”no”。
样例输入

4
[(d+f)*{}]
[(2+3))
()}
[4(6]7)9

样例输出

yes
no
no
no

#include <iostream>
#include <algorithm>
#include <stack>
using namespace std;
int main()
{
    int n;
    stack<char> s;
    while(cin>>n)
    {
        while(n--)
        {
            while(!s.empty())
                s.pop();
            s.push('0');
            string ss;
            cin>>ss;
            for(string::iterator it = ss.begin() ; it != ss.end() ; ++it)
            {
                if(*it != '(' && *it != ')' && *it != '[' && *it != ']' && *it != '{' && *it != '}')
                    continue;
                else if((s.top() == '(' && *it == ')')
                        || (s.top() == '[' && *it == ']')
                        ||(s.top() == '{' && *it == '}'))
                {
                    s.pop();
                }
                else
                {
                    s.push(*it);
                    //cout<<*it<<endl;
                }
            }
            if(s.top() == '0')
                cout<<"yes"<<endl;
            else
                cout<<"no"<<endl;
        }
    }
}

发布了10 篇原创文章 · 获赞 4 · 访问量 231

猜你喜欢

转载自blog.csdn.net/weixin_41414657/article/details/104097471