HDU 3374 String Problem (字符串最大最小表示法模板)

Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Input
Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.
Output
Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.

Sample Input
abcder
aaaaaa
ababab
Sample Output
1 1 6 1
1 6 1 6
1 3 2 3

学到很有趣的思路。

之前遇到那种字符串循环就判相等的题我都是拼接s串再contain的。

原来还可以用“两个序列不按顺序判相等,等于排序后是否相等”。
虽然这题无关这点……
发博客记录模板。

ac代码:

public class Main {
    static int len;
    static int[] next = new int[1000005];

    public static void main(String[] args) {
        Scanner reader = new Scanner(System.in);
        next[0] = -1;
        int num = 1;
        int get = 0;
        while (reader.hasNext()) {
            String in = reader.next();
            len = in.length();
            getPrefix(in.toString());
            get = len - next[len];
            num = 1;// kmp判循环节
            if (len % get == 0) {
                num = len / get;
            }
            System.out.println(minString(in) + " " + num + " " + maxString(in) + " " + num);
        }
    }

    public static int minString(String in) {
        int i = 0, j = 1, k = 0;
        while (i < len && j < len && k < len) {
            int t = in.charAt((i + k) % len) - in.charAt((j + k) % len);
            if (t == 0) {
                k++;
                continue;
            }
            if (t > 0) {
                i += k + 1;
            } else {
                j += k + 1;
            }
            if (i == j) {
                j++;
            }
            k = 0;
        }
        return Math.min(i, j) + 1;
    }

    public static int maxString(String in) {
        int i = 0, j = 1, k = 0;
        while (i < len && j < len && k < len) {
            int t = in.charAt((i + k) % len) - in.charAt((j + k) % len);
            if (t == 0) {
                k++;
                continue;
            }
            if (t > 0) {
                j += k + 1;
            } else {
                i += k + 1;
            }
            if (i == j) {
                j++;
            }
            k = 0;
        }
        return Math.min(i, j) + 1;
    }

    public static void getPrefix(String in) {
        int j = 0, k = -1;
        while (j < len) {
            if (k == -1 || in.charAt(j) == in.charAt(k)) {
                j++;
                k++;
                next[j] = k;
            } else {
                k = next[k];
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/cymbals/article/details/80314667