1007 Maximum Subsequence Sum(DP)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/LightInDarkness/article/details/84891274

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

Analyze:

    This is a classical problem about dynamic programming. We can traversal the array from the beginning to the end and use variable(sum) to record the sum of a continuous subsequence. When sum is less than 0, we should discard this value and set it to be 0. If sum is greater than max, we need to update the value of max. It's also a important point to record i and j(According to the description of the question, they must be the smallest indices). Anaway, the most important thing is to find the optimal substructure, but it's beyond me!

#include<iostream>

using namespace std;

int main(){
	int K, max = -1, sum = 0, first = -1, last = -1, ftmp = 0;
	int a[10000];
	cin >> K;
	for(int i = 0; i < K; i++) cin >> a[i];
	for(int i = 0; i < K; i++){
		sum += a[i];
		if(sum > max){
			max = sum;
			first = a[ftmp];
			last = a[i];
		}
		if(sum < 0){
			sum = 0;
			ftmp = i + 1;
		}
	}
	if(max >= 0) cout << max << ' ' << first << ' ' << last;
	else cout << "0 " << a[0] << ' ' << a[K - 1];
	return 0;
}

猜你喜欢

转载自blog.csdn.net/LightInDarkness/article/details/84891274