PAT (Basic Level) Practice (中文)B1029 旧键盘 (20 分)(C++)(散列)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/86476172

1029 旧键盘 (20 分)
旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。

输入格式:

输入在 2 行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过 80 个字符的串,由字母 A-Z(包括大、小写)、数字 0-9、以及下划线 _(代表空格)组成。题目保证 2 个字符串均非空。

输出格式:

按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有 1 个坏键。

输入样例:

7_This_is_a_test
_hs_s_a_es
输出样例:

7TI


using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

int Key[50] = {0};

int mapping(char ch)//查询该字符的散列位置
{
    if(ch>='a' && ch<='z') return ch-'a';//A~Z在0~25
    else if(ch>='A' && ch<='Z') return ch-'A';
    else if(ch>='0' && ch<='9') return ch-'0' + 26;//0~9在26~35
    return 36;//_在36
}

int main()
{
    char str1[100] = {0}, str2[100] = {0};
    scanf("%s", str1);
    int len1 = strlen(str1);
    int x=0;
    for(int i=0; i<len1; i++)
    {
        x = mapping(str1[i]);
        if(!Key[x]) Key[x] = 1;//在第一个字符中出现,把标志置为1
    }
    scanf("%s", str2);
    int len2 = strlen(str2);
    for(int i=0; i<len2; i++)
    {
        x = mapping(str2[i]);//在第二串字符中出现把标志清零
        Key[x] = 0;
    }
    for(int i=0; i<len1; i++)//再次扫描第一个字符串,若标志为1,说明该按键坏掉了
    {
        x = mapping(str1[i]);
        if(Key[x])
        {
            if(x<26) printf("%c", 'A'+x);
            else if(x<36) printf("%c", '0'+x-26);
            else printf("_");
            Key[x] = 0;//之后记得清零,否则可能会多次输出
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86476172
今日推荐