PAT (Advanced Level) Practice B1092 To Buy or Not to Buy (20 分)(C++) (甲级)(散列)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/86481790

1092 To Buy or Not to Buy (20 分)
Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let’s use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

figbuy.jpg

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY
Sample Output 1:

Yes 8
Sample Input 2:

ppRYYGrrYB225
YrR8RrY
Sample Output 2:

No 2

//B1039 到底买不买 (20 分)英文版
//https://blog.csdn.net/m0_37454852/article/details/86481712

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

char str1[1010] = {0}, str2[1010] = {0};

int Cnt1[100] = {0}, Cnt2[100] = {0};//两个字符串中每个字母的个数

int mapping(char ch)//把字母映射到某个位置上
{
    if(ch >= 'a' && ch <= 'z') return ch-'a';//a~z在0~25
    if(ch >= 'A' && ch <= 'Z') return ch-'A'+26;//A~Z在26~51
    return ch-'0'+52;//0~9在52~62
}

int main()
{
    scanf("%s", str1);
    scanf("%s", str2);
    int len1 = strlen(str1);
    int len2 = strlen(str2);
    int x = 0, cnt = 0, flag = 0;
    for(int i=0; i<len1; i++)//扫描第一个字符串
    {
        x = mapping(str1[i]);
        Cnt1[x]++;
    }
    for(int i=0; i<len2; i++)//扫描第二个字符串
    {
        x = mapping(str2[i]);
        Cnt2[x]++;
    }
    for(int i=0; i<100; i++)//根据两个技术值判断是否足够
    {
        if(!flag && Cnt1[i] >= Cnt2[i]) cnt += Cnt1[i] - Cnt2[i];//足则flag = 0,记录多出的个数
        else
        {
            if(!flag) flag = 1, cnt = 0;//否则flag = 1,cnt清零;计数缺少的个数
            if(Cnt1[i] < Cnt2[i]) cnt += Cnt2[i] - Cnt1[i];
        }
    }
    if(flag) printf("No %d", cnt);//根据要求输出即可
    else printf("Yes %d", cnt);
    return 0;
}


猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86481790
今日推荐