Maximum Subsequence Sum (25 分)

传送门
Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

Sample Input

5
-1 0 -2 0 -3

Sample Output

0 0 0

①因为要维护左右区间,必须开一个数组.
②输出的是value不是index(下标);
③特判

#include<stdio.h>
int main()
{
    
    
	int n;
	scanf("%d",&n);
	int a[n],left=0,right=n-1,sum=0,max=-1,temp=0;//max要初始化为-1才能存入当sum=0时,更新max以及左右元素下标 
	for(int i=0;i<n;i++)
	{
    
    
		scanf("%d",&a[i]);
		sum+=a[i]; 
		if(sum<0) {
    
    sum=0,temp=i+1;}
		else if(sum>max)
		{
    
    
			max=sum;
			left=temp;
			right=i;
		}
	}
	if(max<0)max=0;//特判:当只输入一个数字时 
	printf("%d %d %d",max,a[left],a[right]);
} 

猜你喜欢

转载自blog.csdn.net/weixin_49640089/article/details/114242992