甲级真题 1011 World Cup Betting (20分)

甲级真题 1011 World Cup Betting (20分)

题目原文

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1  2.5  1.7
1.2  3.1  1.6
4.1  1.2  1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1     

Sample Output:

T T W 39.31

生词

accurate up 精确到

关键句

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

为了获得最大的利润,必须在第三次买赢,第二次和第一次买输,每一次赌,赌两元,然后给了一个公式,精确到后面两位.

代码如下

#include<iostream>
#include<cstdio>
using namespace std;
int main(void) {
    double  Max, Sum = 1.0,W, T, L;
    char t;
    for (int i = 0; i < 9; i=i+3) {
        scanf("%lf%lf%lf", &W, &T, &L);
        Max = W;
        t = 'W';
        if (Max<=T) {
            Max = T;
            t= 'T';
        }
        if (Max <=L) {
            Max = L;
            t = 'L';
        }
        Sum *= Max;
        printf("%c ", t);
    }
    printf("%.2f", (Sum * 0.65 - 1.0) * 2);
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/a-small-Trainee/p/12345829.html