PAT甲级真题(结构体排序)——1012. The Best Rank (25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_29978597/article/details/85783575

1012. The Best Rank (25)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C – C Programming Language, M – Mathematics (Calculus or Linear Algebra), and E – English. At the mean time, we encourage students by emphasizing on their best ranks — that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A – Average of 4 students are given as the following:
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output “N/A”.

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

题目大意:

给出每位学生单科成绩,在几项成绩(包括平均成绩)中找出排名最高的成绩。

题目解析:

  • 利用结构体保存学生ID,单科成绩,单科成绩排名,最好成绩;
  • 用sort函数进行结构体排序,然后计算排名,注要意并列的情况;
  • 用exist数组保存学号与数组中序号的关系,方便查询。

具体代码:

#include<iostream>
#include<cstdio>
#include<algorithm> 
using namespace std;

struct node{
	int id,best;
	int grade[4],rank[4];
}stu[2010];

int exist[1000000],flag=-1;
string s="ACME";

bool cmp(node a,node b){
	return b.grade[flag]<a.grade[flag];
}

int main()
{
    int n,m;
    cin>>n>>m;
    //输入学生成绩 
    for(int i=0;i<n;i++){
    	scanf("%d %d %d %d",&stu[i].id,&stu[i].grade[1],&stu[i].grade[2],&stu[i].grade[3]);
    	stu[i].grade[0]=(stu[i].grade[1]+stu[i].grade[2]+stu[i].grade[3])/3;
	}
	
	//计算每个学生各项成绩排名 
    for(flag=0;flag<4;flag++){
    	sort(stu,stu+n,cmp);
    	stu[0].rank[flag]=1;
    	for(int i=1;i<n;i++){
    		if(stu[i].grade[flag]==stu[i-1].grade[flag])
    			stu[i].rank[flag]=stu[i-1].rank[flag];
    		else
    			stu[i].rank[flag]=i+1;
		}
	}
	fill(exist,exist+1000000,-1);
	//计算学生最好排名的科目同时确定其ID与数组序号的关系 
	for(int i=0;i<n;i++){
		exist[stu[i].id]=i;
		int min=0;
		for(int j=1;j<4;j++)
			if(stu[i].rank[j]<stu[i].rank[min])
				min=j;
		stu[i].best=min;
	}
	while(m--){
		int id,k;
		scanf("%d",&id);
		if(exist[id]==-1)
			printf("N/A\n");
		else{
			k=exist[id];
			printf("%d %c\n",stu[k].rank[stu[k].best],s[stu[k].best]);
		}
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_29978597/article/details/85783575