[PAT甲级]1012. The Best Rank (25)(最好排名)

1012. The Best Rank (25)

原题链接

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output “N/A”.

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

题目大意:

  • 给出n个学生的id, C M E的课程成绩,然后给出m个学生的id,输出他们的最好排名和排名的依据(即ACME)
  • 每个学生有四个成绩 C M E和A,A是C M E的平均成绩,每个学生可以有四个排名,若是出现其中两个或者多个排名一样的,优先级为 A > C > M > E

思路:

  • 每个学生有四个排名,先定义一个结构体,存储学生的id,成绩,排名和最好排名
  • 随后输入过程中计算平均成绩A
  • 按照各科成绩进行排名,分别记录
  • 统计每个学生最好排名, 同时用exist数组保存当前id是否存在,这个id对应的结构体的下标是多少。用i+1可以保证为0的都是不存在的可以直接输出N/A,其余不为0的保存的值是对应的结构体index + 1的值
  • 思路参考,点击链接

代码:

#include <iostream>
#include <string>
#include <algorithm>
#include <cstdio>
using namespace std;
struct node{
    int id,best;
    int score[4],rank[4];//分数  排名
}stu[2001];
int exist[1000000];//用于检查d是否存在
int flag = -1;
int cmd(node a, node b){return a.score[flag] > b.score[flag];}
int main()
{
    int n,m;
    cin >> n >> m;//n行学生成绩 m个要输出的人数
    for(int i=0; i<n; i++){
        scanf("%d %d %d %d", &stu[i].id, &stu[i].score[1], &stu[i].score[2], &stu[i].score[3]);
        stu[i].score[0] = (stu[i].score[1]+stu[i].score[2]+stu[i].score[3]+1.5)/3;//四舍五入
    }
    for(flag=0; flag<=3; flag++){//分别记录各科排名
        sort(stu, stu+n, cmd);
        stu[0].rank[flag] = 1;
        for(int i=1; i<n; i++){
            stu[i].rank[flag] = i+1;
            if(stu[i].score[flag] == stu[i-1].score[flag])//排名并列应该1、1、3、4、5,而不是1、1、2、3、4
                stu[i].rank[flag] = stu[i-1].rank[flag];
        }
    }
    for(int i=0; i<n; i++){
        exist[stu[i].id] = i+1;//记录学生目前的排名(最后一次排序)
        stu[i].best = 0;//找出学生四种排名中最好的
        int t = stu[i].rank[0];
        for(int j=1; j<=3; j++){
            if(stu[i].rank[j] < t){
                t = stu[i].rank[j];
                stu[i].best = j;
            }
        }
    }
    char c[] = {'A', 'C', 'M', 'E'};
    for(int i=0; i<m; i++){
        int id;
        scanf("%d", &id);
        int temp = exist[id];
        if(temp != 0){
            int best = stu[temp-1].best;
            printf("%d %c\n", stu[temp-1].rank[best], c[best]);
        }else{
            printf("N/A\n");//id不存在
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/whl_program/article/details/77591531