[Java] 1012. The Best Rank (25)-PAT甲级

1012. The Best Rank (25)
To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C – C Programming Language, M – Mathematics (Calculus or Linear Algebra), and E – English. At the mean time, we encourage students by emphasizing on their best ranks — that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A – Average of 4 students are given as the following:

StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output “N/A”.

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A

题目大意:现已知n个考生的3门分数,平均分可以按照这三门算出来。然后分别对这四个分数从高到低排序,这样对每个考生来说有4个排名。k个查询,对于每一个学生id,输出当前id学生的最好的排名和它对应的分数,如果名次相同,按照A>C>M>E的顺序输出。如果当前id不存在,输出N/A

扫描二维码关注公众号,回复: 2870589 查看本文章

PS:感谢github用户@fs19910227提供的pull request~

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.HashMap;
import java.util.stream.Stream;

public class Main {
    private static BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));

    static class Course {
        enum Name {
            C(2), M(3), E(4), A(1);
            final int rank;

            Name(int rank) {
                this.rank = rank;
            }
        }

        static Name[] names = Name.values();
        final int score;
        final int course_rank;
        final int id;
        final String name;

        Course(int id, int score) {
            this.score = score;
            this.course_rank = names[id].rank;
            this.id = id;
            this.name = names[id].toString();
        }
    }

    static class Student {
        String id;
        Course[] courses;

        Student(String id, Course[] courses) {
            this.id = id;
            this.courses = courses;
        }
    }

    static String readLine() throws IOException {
        return reader.readLine();
    }

    public static void main(String[] args) throws IOException {
        String[] split = readLine().split(" ");
        int student_nums = Integer.valueOf(split[0]);
        int check_student = Integer.valueOf(split[1]);

        //偷个懒,就都用数组存储
        //score  table
        //0,1,2,3 => C,M,E,A
        //[0-100] score=>counts
        int[][] scoreTable = new int[4][101];
        //course,score=>course_rank
        int[][] rankTable = new int[4][101];

        HashMap<String, Student> students = new HashMap<>(1024, 1);
        for (int i = 0; i < student_nums; i++) {
            String[] line = readLine().split(" ");
            String id = line[0];

            //准备课程
            Course[] courses = new Course[4];
            int sum = 0, index = 0;
            for (int j = 1; j < line.length; j++, index++) {
                Integer score = Integer.valueOf(line[j]);
                sum += score;
                courses[index] = new Course(index, score);
                scoreTable[index][score]++;
            }
            //处理平均值
            int avg_score = sum / index;
            courses[index] = new Course(index, avg_score);
            scoreTable[index][avg_score]++;
            //准备学生
            Student student = new Student(id, courses);
            //存储学生
            students.put(id, student);
        }
        //计算rank
        for (int i = 0; i < scoreTable.length; i++) {
            int[] scores = scoreTable[i];
            int rank = 1;
            for (int j = scores.length - 1; j >= 0; j--) {
                int counts = scores[j];
                if (counts > 0) {
                    rankTable[i][j] = rank;
                    rank += counts;
                }
            }
        }
        for (int i = 0; i < check_student; i++) {
            String id = readLine();
            Student student = students.get(id);
            if (student == null) {
                System.out.println("N/A");
            } else {
                Course course = Stream.of(student.courses).min((o1, o2) -> {
                    int rank_1 = rankTable[o1.id][o1.score];
                    int rank_2 = rankTable[o2.id][o2.score];
                    int compare = rank_1 - rank_2;
                    return compare == 0 ? o1.course_rank - o2.course_rank : compare;
                }).get();
                int rank = rankTable[course.id][course.score];
                System.out.println(rank + " " + course.name);
            }
        }
    }
}

猜你喜欢

转载自blog.csdn.net/liuchuo/article/details/81436516