POJ1007 UVA612 UVALive5414 ZOJ1188 HDU1379 Bailian4086 DNA Sorting【排序+逆序数】

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 110791 Accepted: 44366

Description

One measure of "unsortedness’’ in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence "DAABEC’’, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence "AACEDGG’’ has only one inversion (E and D)—it is nearly sorted—while the sequence ``ZWQM’’ has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of "sortedness’’, from "most sorted’’ to ``least sorted’’. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from "most sorted’’ to ``least sorted’’. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

East Central North America 1998

Regionals 1998 >> North America - East Central NA

问题链接POJ1007 DNA Sorting
问题简述:(略)
问题分析
    这个一个排序问题,需要先算一下每个字符串的逆序数,根据逆序数进行排序。算逆序数采用暴力法进行计算。
    若干个相同的题目,输入和输出格式略有不同,代码都分别给出来了!
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序(POJ1007)如下:

/* POJ1007 DNA Sorting */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 50;
const int M = 100;
struct Node {
    char s[N + 1];
    int inv;
} d[M];

bool cmp(Node a, Node b)
{
    return a.inv < b.inv;
}

int main()
{
    int n, m, i, j, k;
    while(~scanf("%d%d", &n, &m)) {
        for(i = 0; i < m; i++) {
            scanf("%s", d[i].s);
            d[i].inv = 0;       /* 计算逆序数 */
            for(j = 0; j < n; j++)
                for(k = j + 1; k < n; k++)
                    if(d[i].s[j] > d[i].s[k])
                        d[i].inv++;
        }

        sort(d, d + m, cmp);

        for(i = 0; i < m; i++)
            printf("%s\n", d[i].s);
    }

    return 0;
}

AC的C语言程序(UVA612 UVALive5414)如下:

/* UVA612 UVALive5414 DNA Sorting */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 50;
const int M = 100;
struct Node {
    char s[N + 1];
    int inv, id;
} d[M];

bool cmp(Node a, Node b)
{
    return a.inv != b.inv ? a.inv < b.inv : a.id < b.id;
}

int main()
{
    int t, n, m, i, j, k;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &n, &m);
        for(i = 0; i < m; i++) {
            scanf("%s", d[i].s);
            d[i].inv = 0;       /* 计算逆序数 */
            for(j = 0; j < n; j++)
                for(k = j + 1; k < n; k++)
                    if(d[i].s[j] > d[i].s[k])
                        d[i].inv++;
            d[i].id = i;
        }

        sort(d, d + m, cmp);

        for(i = 0; i < m; i++)
            printf("%s\n", d[i].s);
        if(t) printf("\n");
    }

    return 0;
}

AC的C语言程序(ZOJ1188)如下:

/* ZOJ1188 DNA Sorting */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 50;
const int M = 100;
struct Node {
    char s[N + 1];
    int inv;
} d[M];

bool cmp(Node a, Node b)
{
    return a.inv < b.inv;
}

int main()
{
    int t, n, m, i, j, k;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &n, &m);
        for(i = 0; i < m; i++) {
            scanf("%s", d[i].s);
            d[i].inv = 0;       /* 计算逆序数 */
            for(j = 0; j < n; j++)
                for(k = j + 1; k < n; k++)
                    if(d[i].s[j] > d[i].s[k])
                        d[i].inv++;
        }

        sort(d, d + m, cmp);

        for(i = 0; i < m; i++)
            printf("%s\n", d[i].s);
        if(t) printf("\n");
    }

    return 0;
}

AC的C语言程序(HDU1379 DNA Sorting)如下:

/* HDU1379 DNA Sorting */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 50;
const int M = 100;
struct Node {
    char s[N + 1];
    int inv;
} d[M];

bool cmp(Node a, Node b)
{
    return a.inv < b.inv;
}

int main()
{
    int t, n, m, i, j, k;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &n, &m);
        for(i = 0; i < m; i++) {
            scanf("%s", d[i].s);
            d[i].inv = 0;       /* 计算逆序数 */
            for(j = 0; j < n; j++)
                for(k = j + 1; k < n; k++)
                    if(d[i].s[j] > d[i].s[k])
                        d[i].inv++;
        }

        sort(d, d + m, cmp);

        for(i = 0; i < m; i++)
            printf("%s\n", d[i].s);
    }

    return 0;
}

AC的C语言程序(Bailian4086 DNA Sorting)如下:

/* Bailian4086 DNA Sorting */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 50;
const int M = 100;
struct Node {
    char s[N + 1];
    int inv, id;
} d[M];

bool cmp(Node a, Node b)
{
    return a.inv != b.inv ? a.inv < b.inv : a.id < b.id;
}

int main()
{
    int n, m, i, j, k;
    while(~scanf("%d%d", &n, &m)) {
        for(i = 0; i < m; i++) {
            scanf("%s", d[i].s);
            d[i].inv = 0;       /* 计算逆序数 */
            for(j = 0; j < n; j++)
                for(k = j + 1; k < n; k++)
                    if(d[i].s[j] > d[i].s[k])
                        d[i].inv++;
            d[i].id = i;
        }

        sort(d, d + m, cmp);

        for(i = 0; i < m; i++)
            printf("%s\n", d[i].s);
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/85482594