DNA Sorting

 
      
1903: DNA Sorting  分享至QQ空间  去爱问答提问或回答
Time Limit(Common/Java):1000MS/10000MS     Memory Limit:65536KByte
Total Submit: 607            Accepted:347

Description

One measure of "unsortedness" in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence "DAABEC", this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence "AACEDGG" has only one inversion (E and D)--it is nearly sorted--while the sequence "ZWQM" has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of "sortedness", from "most sorted" to "least sorted". All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n ≤ 50) giving the length of the strings; and a positive integer m (1 < m ≤ 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from "most sorted" to "least sorted". If two or more strings are equally sorted, list them in the same order they are in the input.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
struct node
{
	char str[51];
	int num;//用结构体,num用于记数 
}a[101];
bool cmp(node a,node b)
{
	return a.num < b.num;
}
void Count(int In,int n,int m)
{
	int i,j,measure = 0;
	for(i = 0; i < n - 1; i++)
	{
		if(a[In].str[i] == 'A')
			continue;
		for(j = i + 1; j < n; j++)
		{
			if(a[In].str[i] > a[In].str[j])
				measure++; //左边 大于右边加一 
		}
	}
	a[In].num = measure;
}

int main()
{
	int n,m,i,j,k;
	scanf("%d%d",&n,&m);
	{
		for(i = 0; i < m; i++)
		{
			scanf("%s",a[i].str);
			Count(i,n,m);
		}
		sort(a,a+m,cmp);	
		for(i = 0; i < m ; i++)
			printf("%s\n",a[i].str);
	}
}




猜你喜欢

转载自blog.csdn.net/u013780740/article/details/28429965
DNA