POJ2021 HDU1311 ZOJ2021 UVALive3071 Relative Relatives【排序】

Relative Relatives

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 3867   Accepted: 1713

Description

Today is Ted's 100th birthday. A few weeks ago, you were selected by the family to contact all of Ted's descendants and organize a surprise party. To make this task easier, you created an age-prioritized list of everyone descended from Ted. Descendants of the same age are listed in dictionary order. 

The only materials you had to aid you were birth certificates. Oddly enough, these birth certificates were not dated. They simply listed the father's name, the child's name, and the father's exact age when the baby was born.

Input

Input to this problem will begin with line containing a single integer n indicating the number of data sets. Each data set will be formatted according to the following description. 

A single data set has 2 components: 

  1. Descendant Count - A line containing a single integer X (where 0 < X < 100) indicating the number of Ted's descendants. 
  2. Birth Certificate List - Data for X birth certificates, with one certificate's data per line. Each certificate's data will be of the format "FNAME CNAME FAGE" where: 
    • FNAME is the father's name. 
    • CNAME is the child's name. 
    • FAGE is the integer age of the father on the date of CNAMEs birth.


Note: 

  • Names are unique identifiers of individuals and contain no embedded white space. 
  • All of Ted's descendants share Ted's birthday. Therefore, the age difference between any two is an integer number of years. (For those of you that are really picky, assume they were all born at the exact same hour, minute, second, etc... of their birth year.) 
  • You have a birth certificate for all of Ted's descendants (a complete collection).

Output

For each data set, there will be X+1 lines of output. The first will read, "DATASET Y", where Y is 1 for the first data set, 2 for the second, etc. The subsequent X lines constitute your age-prioritized list of Ted's descendants along with their ages using the format "NAME AGE". Descendants of the same age will be listed in dictionary order.

Sample Input

2
1
Ted Bill 25
4
Ray James 40
James Beelzebub 17
Ray Mark 75
Ted Ray 20

Sample Output

DATASET 1
Bill 75
DATASET 2
Ray 80
James 40
Beelzebub 23
Mark 5

Source

South Central USA 2004

Regionals 2004 >> North America - South Central USA

问题链接POJ2021 HDU1311 ZOJ2021 UVALive3071 Relative Relatives

问题简述: 

  今天是Ted的100岁生日。巧的是,他家族里面每个人都跟他同一天生日,但是年份不同。现在只给出一些父亲与孩子的名字以及孩子出生时父亲的年龄。计算输出Ted以外的家族成员,按年龄降序排序,如果年龄相同,则按字母排序。

问题分析

  这个题的正解应该是建立一颗家族树(或图),然后进行树的遍历。遍历算法可以使用BFS或DFS。

  这里采用的是暴力法,用排序实现。数据规模小的时候,还可以勉强AC,但不是最佳做法。

程序说明:(略)

题记:(略)

参考链接:(略)

AC的C++语言程序如下:

/* POJ2021 HDU1311 ZOJ2021 UVALive3071 Relative Relatives */

#include <iostream>
#include <algorithm>

using namespace std;

const int N = 100;
string father[N], child[N];
int year[N];
struct Descent {
    string name;
    int age;
} descent[N];

bool cmp(Descent a, Descent b)
{
    return (a.age == b.age) ? a.name < b.name : a.age > b.age;
}

int main()
{
    int t, n, caseno = 0;
    cin >> t;
    while(t--) {
        cin >> n;
        for(int i = 0; i < n; i++)
            cin >> father[i] >> child[i] >> year[i];

        int cur = 0, cnt = 1;
        descent[0].age = 100;
        descent[0].name = "Ted";
        for(int i = 0; cur < cnt && i < n; i++, cur++) {
            for(int j = 0; j < n; j++) {
                if(descent[cur].name == father[j]) {
                    descent[cnt].name = child[j];
                    descent[cnt++].age = descent[i].age - year[j];
                }
            }
        }

        sort(descent, descent + cnt, cmp);

        cout << "DATASET " << ++caseno << endl;
        for(int i = 1; i < cnt; i++)
            cout << descent[i].name << " " << descent[i].age << endl;
    }


    return 0;
}

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/81460113