hdu 1151

 

Air Raid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6389    Accepted Submission(s): 4230

 

Problem Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

 

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

题意:最少需要多少个伞兵才能按照图遍历图中的所有顶点,图是无环的有向图

由此可知,这道题求的是最小路径覆盖,意思就是说最少需要多少条路径能够覆盖图中所有顶点

最小路径覆盖 = 顶点数 - 最大匹配

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 1e5+5;
struct Hungary {
	int n, m;
	int mp[500][500];
	int link[maxn], vis[maxn];
	void init(int n, int m)
	{
		this -> n = n;
		this -> m = m;
		memset(link, -1, sizeof(link));
		memset(mp, 0, sizeof(mp));
	}
	void addEdge(int s, int t)
	{
		mp[s][t] = 1;	// 根据题目需要可以改有向或无向 
	}
	int find(int k)
	{
		for(int i = 1;i <= m;i ++)
		{
			if(mp[k][i] && vis[i] == 0)
			{
				vis[i] = 1;
				if(link[i] == -1 || find(link[i]))
				{
					link[i] = k;
					return 1;
				}
			}
		}
		return 0;
	}
	int maxmatch()
	{
		int ans = 0;
		for(int i = 1;i <= n;i ++)
		{
			memset(vis, 0, sizeof(vis));
			if(find(i)) ans ++;
		}
		return ans;
	}
	
}Match;
int main()
{
	int T, n, k;
	cin >> T;
	while(T --)
	{
		scanf("%d%d", &n, &k);
		Match.init(n, n);
		for(int i = 0;i < k;i ++)
		{
			int a, b;
			scanf("%d%d", &a, &b);
			Match.addEdge(a, b);
		}
		printf("%d\n", n - Match.maxmatch());
	}
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/qq_41695941/article/details/81707463