hdu1131

Count the Trees

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2544    Accepted Submission(s): 1562


 

Problem Description

Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power of the brain is applied to something extremely interesting or challenging. 
Juan is a very gifted programmer, and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately, his loved ones are worried about him, because he has found a new exciting problem to exercise his intellectual powers, and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactly n different elements. 

For example, given one element A, just one binary tree can be formed (using A as the root of the tree). With two elements, A and B, four different binary trees can be created, as shown in the figure. 

If you are able to provide a solution for this problem, Juan will be able to talk again, and his friends and family will be forever grateful. 

 

 

Input

The input will consist of several input cases, one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 100 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed. 

 

Output

For each input case print the number of binary trees that can be built using the n elements, followed by a newline character. 

 

Sample Input

 

1 2 10 25 0

 

Sample Output

 

1 4 60949324800 75414671852339208296275849248768000000

 

Source

UVA

卡特兰数应用  

题的意思就是给你n个点  问你能构成 多少种二叉树  

那么我们普通的卡特兰数序列  是指 以一个固定的点为根构建 的种数

题中说每一个点都可以为根  ,

所以直接用原来的卡特兰序列  乘以对应n的阶乘即可

依然是java大整数+卡特兰典序应用


import java.io.*;
import java.math.*;
import java.util.*;

public class Main {
	
	public static void main(String[] args){
		
		Scanner sc = new Scanner(System.in);
		
		BigInteger s[] = new BigInteger[105];
		BigInteger s2[] = new BigInteger[105];
		
		s[1] = BigInteger.ONE;
		for(int i = 2;i < 105;i ++){
			
			s[i] = s[i-1].multiply(BigInteger.valueOf(4 * i - 2)).divide(BigInteger.valueOf(i + 1));
				
		}
		
		s2[1] = BigInteger.ONE;
		
		for(int i = 2;i <= 100;i ++){
			
			s2[i] = s2[i-1].multiply(BigInteger.valueOf(i));
		}
		
		while(true){
			
			int n =  sc.nextInt();
			if(n == 0){
				break;
			}
			else
			System.out.println(s[n].multiply(s2[n]));
		}
	}
}

猜你喜欢

转载自blog.csdn.net/Soul_97/article/details/81389601
今日推荐