HDU-1051——Wooden Sticks

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/kongsanjin/article/details/84892068

                                        Wooden Sticks

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3

5

4 9 5 2 2 1 3 5 1 4

3

2 2 1 1 2 2

3

1 3 2 2 3 1

Sample Output

2

扫描二维码关注公众号,回复: 4425146 查看本文章

1

3

题意描述:

共有n个木棒,已知每个木棒的长度和重量,第一个木棒加工安装需要一分钟,在加工长度l和重量w的棒材之后,如果l<=l'和w<=w',机器将不需要长度l'和重量w'的棒材的安装时间。否则,安装需要1分钟。求加工n个木棒的最小时间。

解题思路:

将木棒根据长度进行从小到大排序,找排序后木棒的重量序列的上升序列有多少段,就需要多少分钟。

程序代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct A
{
	int a;
	int b;
}q[5010];
int cmp(A x,A y)
{
	if(x.a==y.a)
		return x.b<y.b;
	return x.a<y.a;
}
int main()
{
	int t,n,i,j,num,ans,m,x,y;
	int book[5010];
	scanf("%d",&t);
	while(t--)
	{
		memset(book,0,sizeof(book));
		num=0;
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d%d",&q[i].a,&q[i].b);
		sort(q,q+n,cmp);
		ans=0;
		while(ans<n)
		{
			for(i=0;i<n;i++)
			{
				if(book[i]==0)
				{
					book[i]=1;
					x=q[i].a;
					y=q[i].b;
					ans++;
					m=i;
					num++;
					break;
				}
			}
			for(i=m;i<n;i++)
			{
				if(x<=q[i].a&&y<=q[i].b&&book[i]==0)
				{
					book[i]=1;
					x=q[i].a;
					y=q[i].b;
					ans++;
				}
			}
		}
		printf("%d\n",num);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/kongsanjin/article/details/84892068
今日推荐