HDU1151 Air Raid【二分图 最小路径覆盖】

Air Raid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6562    Accepted Submission(s): 4357


 

Problem Description

Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.

Input

Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.

Sample Input

2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3

Sample Output

2
1

Source

Asia 2002, Dhaka (Bengal)

问题链接:HDU1151 Air Raid

问题描述:hdu 1151 最小路径覆盖
题目大意:在一个城镇,有n个路口,m条路,这些路都是单向的,而且路不会形成环,现在要弄一些伞兵去巡查这个城镇,伞兵只能沿着路的方向走,问最少需要多少伞兵才能把所有的路口搜一遍。
解题思路:求解有向无环图的最小路径覆盖,有向无环图的最小路径覆盖=该图的顶点数-该图的最大匹配

AC的C++程序

#include<iostream>
#include<vector>
#include<cstring>

using namespace std;

const int N=200;

vector<int>g[N];
bool vis[N];
int link[N];

bool find(int x)
{
	for(int i=0;i<g[x].size();i++)
	{
		int y=g[x][i];
		if(!vis[y])
		{
			vis[y]=true;
			if(link[y]==-1||find(link[y]))
			{
				link[y]=x;
				return true;
			}
		}
	}
	return false;
}

int main()
{
	int t,n,m,a,b;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(int i=0;i<=n;i++)
		  g[i].clear();
		while(m--)
		{
			scanf("%d%d",&a,&b);
			g[a].push_back(b);
		}
		int cnt=0;
		memset(link,-1,sizeof(link));
		for(int i=1;i<=n;i++)
		{
			memset(vis,false,sizeof(vis));
			if(find(i))
			  cnt++;
		}
		printf("%d\n",n-cnt);//最小路径覆盖 
	}
	return 0; 
}

猜你喜欢

转载自blog.csdn.net/SongBai1997/article/details/84677711