hdu1150 Machine Schedule

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10318    Accepted Submission(s): 5140


Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
 
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
 
  
3
 

Source
 

Recommend

Ignatius.L   |   We have carefully selected several similar problems for you:  1068 1281 1507 1528 1054 



题解:

将A机器和B机器的模式分成二分图的左右部,然后对于每个任务在x,y之间连边。

然后求最小顶点覆盖。

最小顶点覆盖=最大匹配数


代码:

#include<bits/stdc++.h>
using namespace std;
int n1,n2,n,e[100001],head[100001],nexr[100001],map1[100001],g[100001],tot;
void build(int t,int k){
	tot++;
	e[tot]=k;
	nexr[tot]=head[t];head[t]=tot;
}
int pd(int x){
	int i;
	for(i=head[x];i;i=nexr[i])
	 if(!map1[e[i]]){
	 	map1[e[i]]=1;
	 	if(!g[e[i]]||pd(g[e[i]])){
	 		g[e[i]]=x;
	 		return 1;
	 	}
	 }
	 return 0;
}
int main(){
	int i,t,k,ans=0,t1;
	while(1){
		scanf("%d",&n1);
		if(!n1)return 0;
		tot=0;
		memset(head,0,sizeof(head));
		memset(g,0,sizeof(g));
		scanf("%d%d",&n2,&n);
		for(i=1;i<=n;i++){
			scanf("%d%d%d",&t1,&t,&k);
			build(t,k);
		}
		for(i=1;i<=n1;i++){
			memset(map1,0,sizeof(map1));
			if(pd(i))ans++;
		}
		printf("%d\n",ans);
		ans=0;
	}
}

猜你喜欢

转载自blog.csdn.net/qq_41510496/article/details/80898054
今日推荐