PAT乙级 1073 多选题常见计分法 (20 分)

批改多选题是比较麻烦的事情,有很多不同的计分方法。有一种最常见的计分方法是:如果考生选择了部分正确选项,并且没有选择任何错误选项,则得到 50% 分数;如果考生选择了任何一个错误的选项,则不能得分。本题就请你写个程序帮助老师批改多选题,并且指出哪道题的哪个选项错的人最多。

输入格式:

输入在第一行给出两个正整数 N(≤1000)和 M(≤100),分别是学生人数和多选题的个数。随后 M 行,每行顺次给出一道题的满分值(不超过 5 的正整数)、选项个数(不少于 2 且不超过 5 的正整数)、正确选项个数(不超过选项个数的正整数)、所有正确选项。注意每题的选项从小写英文字母 a 开始顺次排列。各项间以 1 个空格分隔。最后 N 行,每行给出一个学生的答题情况,其每题答案格式为 (选中的选项个数 选项1 ……),按题目顺序给出。注意:题目保证学生的答题情况是合法的,即不存在选中的选项数超过实际选项数的情况。

输出格式:

按照输入的顺序给出每个学生的得分,每个分数占一行,输出小数点后 1 位。最后输出错得最多的题目选项的信息,格式为:错误次数 题目编号(题目按照输入的顺序从1开始编号)-选项号。如果有并列,则每行一个选项,按题目编号递增顺序输出;再并列则按选项号递增顺序输出。行首尾不得有多余空格。如果所有题目都没有人错,则在最后一行输出 Too simple。

输入样例 1:

3 4
3 4 2 a c
2 5 1 b
5 3 2 b c
1 5 4 a b d e
(2 a c) (3 b d e) (2 a c) (3 a b e)
(2 a c) (1 b) (2 a b) (4 a b d e)
(2 b d) (1 e) (1 c) (4 a b c d)

输出样例 1:

3.5
6.0
2.5
2 2-e
2 3-a
2 3-b

输入样例 2:

2 2
3 4 2 a c
2 5 1 b
(2 a c) (1 b)
(2 a c) (1 b)

输出样例 2:

5.0
5.0
Too simple

思路:

有个坑:不光要计算错误的项,还要计算漏选的项。
在这里插入图片描述

代码:

#include<stdio.h>
#include<string.h>
int main(){
	int N,M;//学生人数和多选题的个数
	scanf("%d %d",&N,&M);
	int mark[101],right_options[101][6]={0};//存放每道题的满分值,正确选项个数与正确选项
	for(int i=0;i<M;++i){
		int temp;
		scanf("%d %d %d",&mark[i],&temp,&right_options[i][5]);
		char ch;
		while((ch=getchar())!='\n') if(ch!=' ') right_options[i][ch-'a']=1;
	}//题目信息的录入
	int answers[6]={0},wrong_options[101][6]={0},miss_options[101][6]={0},sign_wrong,max=0;
	for(int i=0;i<N;++i){
		double score=0;
		char ch;
		int cnt=0;
		while((ch=getchar())!='\n'){
			if(ch!='('&&ch!=' '&&ch!=')'){
				if(ch>='0'&&ch<='9') answers[5]=ch-'0';
				else answers[ch-'a']=1;
			}
			else if(ch=='('){
				answers[0]=0,answers[1]=0,answers[2]=0,answers[3]=0,answers[4]=0,answers[5]=0,sign_wrong=0;
			}
			else if(ch==')'){
				for(int j=0;j<5;++j){
					if(answers[j]!=right_options[cnt][j]){
						if(answers[j]){
							sign_wrong=1,++wrong_options[cnt][j];
							if(max<wrong_options[cnt][j]) max=wrong_options[cnt][j];
						}  
						else{
							++miss_options[cnt][j];
							if(max<miss_options[cnt][j]) max=miss_options[cnt][j];
						} 
					}
				}
				if(sign_wrong) ++wrong_options[cnt++][5];
				else{
					if(answers[5]<right_options[cnt][5]) score+=mark[cnt++]/2.0;
					else if(answers[5]==right_options[cnt][5]) score+=mark[cnt++]*1.0;
				}
			}
		}
		cnt=0,printf("%.1lf\n",score);
	}
	if(max){
		for(int i=0;i<M;++i){
			for(int j=0;j<5;++j){
				if(wrong_options[i][j]==max) printf("%d %d-%c\n",max,i+1,j+'a');
				if(miss_options[i][j]==max) printf("%d %d-%c\n",max,i+1,j+'a');
			}
		}
	}
	else{
		printf("Too simple\n");
	}
	return 0;
}

在这里插入图片描述

猜你喜欢

转载自blog.csdn.net/qq_37205425/article/details/84887365