7-35 词频统计 (30 分)

请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。
所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。

输入格式:
输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。

输出格式:
在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。
随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。

输入样例:

This is a test.

The word “this” is the word with the highest frequency.

Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee. But this_8 is different than this, and this, and this…#
this line should be ignored.

输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)
23
5:this
4:is

  • 词频统计——map;
  • 按词频排序——vector(可设置结构体,亦可使用make_pair());

使用make_pair():

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<map>
#include<algorithm>
#include<cmath>
#include<vector>
using namespace std;
map<string,int> mp;
vector<pair<string,int> > v;
bool cmp(pair<string,int> a,pair<string,int> b){
 if(a.second!=b.second) return a.second>b.second;
 else return a.first<b.first;
}
int main() {
 string s;
 char ch;
 while(~scanf("%c",&ch)&&ch!='#') {
  if(ch>='a'&&ch<='z'||ch>='A'&&ch<='Z'||ch>='0'&&ch<='9'||ch=='_') {
   if(ch>='A'&&ch<='Z') ch=ch-'A'+'a';
   if(s.size()<15) s+=ch;
  }
  else{
   if(s.size()>0){
    mp[s]++;
    s.clear();
   }
  }
 }
 map<string,int>::iterator it;
 for(it=mp.begin();it!=mp.end();it++){
  v.push_back(make_pair(it->first,it->second));
 }
 sort(v.begin(),v.end(),cmp);
 
 cout<<v.size()<<endl;
 int len=v.size()/10;
 for(int i=0;i<len;i++){
  cout<<v[i].second<<":"<<v[i].first<<endl;
 }
 return 0;
}

使用结构体:

#include<iostream>
#include<cstdio>
#include<map>
#include<string>
#include<vector>
#include<algorithm>
using namespace std;
struct node{
 string s;
 int num;
}p;
map<string,int> mp;
map<string,int>::iterator it;
vector<node> v;
bool cmp(node a,node b){
 if(a.num!=b.num)
 return a.num>b.num;
 else
 return a.s<b.s; 
}
int main(){
 string s="";
 char c;
 while(~scanf("%c",&c)){
  if((c>='A'&&c<='Z')||(c>='a'&&c<='z')||(c>='0'&c<='9')||(c=='_')){
   if(c>='A'&&c<='Z')
   c=c-'A'+'a';
   if(s.size()<15)
   s+=c;
  }
  else{//单词分隔符
   if(s.size()!=0){
    mp[s]++;
    s="";
   }
   if(c=='#')
   break;
  }
 }
 for(it=mp.begin();it!=mp.end();++it){
  p.s=it->first;
  p.num=it->second;
  v.push_back(p);
 }
 sort(v.begin(),v.end(),cmp);
 cout<<v.size()<<endl;
 int m=v.size()/10;
 for(int i=0;i<m;i++){
  cout<<v[i].num<<":"<<v[i].s<<endl;
 }
 return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_39825375/article/details/84889491