7-3 词频统计(30 分) 巧解

版权声明:如果是原创仅供参考,转请标明出处。 https://blog.csdn.net/oShuaiFeng/article/details/81702609

2018年8月15日 于山东

7-3 词频统计(30 分)

请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。

所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。

输入格式:

输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。

输出格式:

在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。

随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。

输入样例:

This is a test.

The word "this" is the word with the highest frequency.

Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee.  But this_8 is different than this, and this, and this...#
this line should be ignored.

输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)

23
5:this
4:is

这道题其实不难,只是有些东西题目并没有给清楚。

坑:看输出格式的提示里 “注意“单词”不区分英文大小写” 这句话 ,你既然是在输出格式里写出,就会指引我们往输出不论是da'x大小写都是正确的 结果呢?只有小写过了,大写却没过。

技巧:使用匹配攻破之。scanf

​
#define _CRT_SECURE_NO_WARNINGS
#include "bits/stdc++.h"
using namespace std;

struct stx {
	string t;
	int x;
}Px[100000+10];
int pxcnt = 0;
bool cmp(struct stx A, struct stx B) {
	if (A.x < B.x) return false;
	else if (A.x == B.x && A.t>B.t) return false;
	return true;
}
class newgame {
public:
	string t;
	map<string, int>KS;
	void run() {
		tsolve();
	}
private:
	void tsolve() {
		char PTS[5000];
		while (!strstr(PTS,"#")) {
			int numk = scanf("%800[A-Za-z0-9_#]", PTS); // 输入匹配
			PTS[15] = 0;
			if (numk) {
				t = PTS;
				transform(t.begin(), t.end(), t.begin(), ::tolower); // 转小写
				if (strstr(PTS, "#")) t[t.size() - 1] = 0;
				if(t[0]!=0)	KS[t]++;
			}
			getchar();
		}
		printf("%d\n",KS.size());

		for (map<string, int>::iterator it = KS.begin(); it != KS.end(); it++) Px[pxcnt++] = { it->first,it->second };
		sort(Px, Px + pxcnt, cmp);
		int cdnum = KS.size()*0.1;
		for (int i = 0; i < cdnum; i++) {
			cout << Px[i].x << ":" << Px[i].t << endl;
		}
	}
};

int main() {

	newgame P;
	P.run();
	system("pause");
	return 0;
}

​

使用匹配时候务必小心死循环 造成这个原因是 scanf又接收了回车造成!!!需要加上getchar()

猜你喜欢

转载自blog.csdn.net/oShuaiFeng/article/details/81702609