第7章-1 词频统计 (30分)【Python版本】

 

请编写程序,对一段英文文本,统计其中所有不同单词的个数,以及词频最大的前10%的单词。

所谓“单词”,是指由不超过80个单词字符组成的连续字符串,但长度超过15的单词将只截取保留前15个单词字符。而合法的“单词字符”为大小写字母、数字和下划线,其它字符均认为是单词分隔符。

输入格式:

输入给出一段非空文本,最后以符号#结尾。输入保证存在至少10个不同的单词。

输出格式:

在第一行中输出文本中所有不同单词的个数。注意“单词”不区分英文大小写,例如“PAT”和“pat”被认为是同一个单词。

随后按照词频递减的顺序,按照词频:单词的格式输出词频最大的前10%的单词。若有并列,则按递增字典序输出。

输入样例:

This is a test.

The word "this" is the word with the highest frequency.

Longlonglonglongword should be cut off, so is considered as the same as longlonglonglonee.  But this_8 is different than this, and this, and this...#
this line should be ignored.

输出样例:(注意:虽然单词the也出现了4次,但因为我们只要输出前10%(即23个单词中的前2个)单词,而按照字母序,the排第3位,所以不输出。)

23
5:this
4:is

【Python参考代码】

#By yangbo 2020.08.11
#来自:https://blog.csdn.net/qq_43479432/article/details/105012204?utm_medium=distribute.pc_aggpage_search_result.none-task-blog-2~all~first_rank_v2~rank_v25-4-105012204.nonecase
import sys
s = sys.stdin.read()
s = s[:s.find('#')]  #读写所有内容,输入 ctrl+d 结束

for i in s:          #将所有非字母、非数字、非下划线的字符均用空格替换
    if i.isalnum() == False and i != '_':
        s = s.replace(i, ' ')
        
words1 = s.lower().split(' ')  #以空格分隔各个单词并存储它们的小写

words2 = {}
for i in words1:
    if i == '':      #上一步分隔后,可能存在分隔了两个空格存留的空字符,将其略过
        continue
    else:
        i = i[:15]   #保留所有单词的前十五位
        words2[i] = words2.get(i, 0) + 1#如果字典中有这个键,则值加一,若没有,则创建一个并令值等于零

#将字典先按“值”倒序排列,大的在前,最大的数前面加个符号就变的最小,这样排得越前
#然后再按“键”排列,即相同数量时,按字母顺序排列

words3 = sorted(words2.items(), key=lambda x:(-x[1],x[0]))#-x[1]:将字典先按“值”倒序排列

print(len(words3))
num = int(len(words3) / 10) #输出前10%的单词
for i in range(num):
    print(str(words3[i][1]) + ':' + str(words3[i][0]))

猜你喜欢

转载自blog.csdn.net/qq_38689263/article/details/107935069