A1036 Boys vs Girls (25分)

1036 Boys vs Girls (25分)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade
​F​​ −grade​M If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

题解:

  • 查找最大的female分数。和最小的male分数。并按照格式输出。
#include <string>
#include <iostream>
using namespace std;
struct People{
	string name;
	string couse;
	int grade;
}temp,female,male;
int main(){
	int n;
	cin >> n;
	female.name="";female.grade=0;
	male.name="";male.grade=101;
	string sex;
	while(n--!=0){
		cin>>temp.name >> sex >> temp.couse >>temp.grade;
		if(sex=="M"&&temp.grade<male.grade){
			male.name=temp.name;
			male.couse=temp.couse;
			male.grade=temp.grade;
		}else if(sex=="F"&&temp.grade>female.grade){
			female.name=temp.name;
			female.couse=temp.couse;
			female.grade=temp.grade;
		}
	}
	if(female.name==""){
		cout << "Absent" <<endl;
	}else cout << female.name <<" " <<female.couse <<endl;
	if(male.name==""){
		cout << "Absent" <<endl;
	}else cout <<male.name <<" "<< male.couse << endl;
	
	if(female.name==""||male.name==""){
		cout << "NA" ; 
	}else cout << female.grade-male.grade; 
	return 0;	
}
发布了91 篇原创文章 · 获赞 9 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/WeDon_t/article/details/105300891