I - Wooden Sticks

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

题意:n个木头,每个木头都有一个l长度,w宽度,要加工这n个木头,加工一块木头需要1分钟,当前面的木头的l,w都大于后面木头的l,w,这两块木头可以同时加工,问最小需要加工多长时间。

思路:本质就是求这n个数列中有多少个递减子序列。

#include<iostream>
#include<algorithm>
using namespace std;
struct hah
{
    int l;
    int w;
    bool p;//标记元素是否被找过

};

bool cmp(hah a,hah b)//首先按长度从大到下排序,长度相同的按重量从大到小排序
{
    if(a.l==b.l)
        return a.w>b.w;
    return a.l>b.l;
}
int main()
{
    hah m[10000];

    int t;
    cin>>t;
    int n;
    while(t--)
    {
        cin>>n;
        for(int i=0; i<n; i++)
        {
            cin>>m[i].l>>m[i].w;
            m[i].p=0;
        }
        sort(m,m+n,cmp);
        int num=0;
        int res=0;
        hah temp;
        while(1)
        {
            if(num==n)
                break;
            for(int i=0; i<n; i++)//每次启动时寻找未被标记过的元素中的最大值。
            {
                if(!m[i].p)
                {
                    temp=m[i];
                    break;
                }
            }
            for(int i=0;i<n;i++)
            {
                if(!m[i].p&&m[i].l<=temp.l&&m[i].w<=temp.w)//寻找递减数列
                {
                    num++;//计数
                    m[i].p=1;//将找过的元素标记
                    temp=m[i];//更新最大数
                }
            }
            res++;//每次启动完成一个递减序列
        }
        cout<<res<<endl;

    }
    return 0;


}

猜你喜欢

转载自blog.csdn.net/zhouchenghao123/article/details/83685592
今日推荐