D - Wooden Sticks

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
InputThe input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
OutputThe output should contain the minimum setup time in minutes, one per line.
Sample Input
3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1
Sample Output
 
 

2 1 3

     思路:先按长度不同,重量从大到小进行排序,长度相同的,重量递减;

               再就是进行比较,设定一个min,  if min 大于等于后面的重量,就算进来,用一个数组标记;用一个sun总和;
                就是加黑代码部分最重要;
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct mood
{
    int l;
    int w;
}mo[5005];
int flag[5005];
bool cmp(mood a,mood b)
{
    if(a.l!=b.l)
        return a.l>b.l;
    return a.w>b.w;
}
int main()
{
     int n;
     scanf("%d",&n);
     for(int i=0;i<n;i++)
     {
           int a;
           scanf("%d",&a);
           for(int j=0;j<a;j++)
           {
               scanf("%d %d",&mo[j].l,&mo[j].w);
               flag[j]=0;
           }
            sort(mo,mo+a,cmp);
            int sum=0,mi;
         for(int j=0;j<a;j++)
         {
              if(flag[j]) continue;
              mi=mo[j].w;
              for(int q=j+1;q<a;q++)
              {
                    if(mo[q].w<=mi&&!flag[q])
                    {
                         mi=mo[q].w;
                         flag[q]=1;
                    }
              }
              sum++;
         }

        printf("%d\n",sum);
     }
return 0;
}

猜你喜欢

转载自blog.csdn.net/hnust_lec/article/details/79311463