HDU 1051Wooden Sticks

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1

Sample Output

2 1 3

简单贪心......

#include<iostream>
#include<algorithm>
using namespace std;
int t, n;
struct node
{
	int l;
	int w;
};
int cmp1(node a, node b)
{
	if (a.l == b.l)
		return a.w > b.w;
	else
		return a.l > b.l;
}
int main()
{
	cin >> t;
	while (t--)
	{
		cin >> n;
		node box[5010], ans[5010];
		for (int i = 1; i <= n; i++)
			cin >> box[i].l >> box[i].w;
		sort(box + 1, box + n + 1, cmp1);
		int k = 1;
		ans[1] = box[1];
		for (int i = 2; i <= n; i++)
		{
			int flag = 0;
			for (int j = 1; j <= k; j++)
			{
				if (box[i].l <= ans[j].l&&box[i].w <= ans[j].w)
				{
					ans[j].l = box[i].l, ans[j].w = box[i].w;
					flag = 1;
					break;
				}
			}
			if (!flag)
				ans[++k] = box[i];
		}
		if (n == 0)
			cout << '0' << endl;
		else
		cout << k<< endl;
	}
	return 0;
}

再附上JAVA版:

import java.util.*;
class node implements Comparable
{
	public int l;
	public int w;
	node(int x1,int x2)      //初始构造方法
	{
		this.l=x1;
		this.w=x2;
	}
	public int compareTo(Object o)
	{
		node n=(node)o;
		if(l==n.l)
		{
			if(w<n.w)
				return 1;
			else if(w>n.w)
				return -1;
			else
				return 0;
		}
		else
		{
			if(l<n.l)
				return 1;
			else 
				return -1;
		}
	}
}
public class Main {
	
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		int t=sc.nextInt();
		for(int i=0;i<t;i++)
		{
			int num=0;
			node ans[]=new node[5001];
			int n=sc.nextInt();
			node box[]=new node[5001];
			for(int j=1;j<=n;j++) {
				int tmp1=sc.nextInt(),tmp2=sc.nextInt();
				box[j]=new node(tmp1,tmp2);     //对于box的赋值需要使用其构造方法
			}
			Arrays.sort(box,1,n+1);
			for(int j=1;j<=n;j++)
			{
				int flag=0;
				for(int k=0;k<num;k++) {
					if(box[j].l<=ans[k].l&&box[j].w<=ans[k].w)
					{
						ans[k].l=box[j].l;
						ans[k].w=box[j].w;
						flag=1;
						break;
					}
				}
				if(flag==0)
				{
					ans[num++]=new node(box[j].l,box[j].w);  //同样对于ans的赋值也需要使用其构造方法
				}
			}
			System.out.println(num);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/slience_646898/article/details/82748647