HDU 1.3.5 Wooden Sticks

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 
Output
The output should contain the minimum setup time in minutes, one per line.
 
Sample Input
3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1
 
Sample Output
2
1
3
 
 
Source
Asia 2001, Taejon (South Korea)
 
 

【思路】

把wooden stick按length排序。

不断循环(很多个for,嵌套在while里面),若下一个stick的length和weight都大于等于前一个处理的stick,那么删掉这个stick。

每一次循环开始时都增加1 min的 preprocess time.

#include<stdio.h>  
#include"algorithm"  
using namespace std;  
struct stick{  
    int length;  
    int weight;  
    bool deleted = false;  
};  
int cmp(const stick &a, const stick &b)  
{  
    return a.length < b.length;  
}  
int larger(const stick &a, const int l,const int w)  
{  
    return a.length >= l&&a.weight >=w;  
}  
stick st[5000];  
int main()  
{  
    freopen("f://in.txt", "r", stdin);  
    freopen("f://out.txt", "w", stdout);  
    int testCase;  
    scanf("%d", &testCase);  
    while (testCase--)  
    {  
        memset(st, 0, sizeof(st));  
        int stickNum;  
        scanf("%d", &stickNum);  
        for (int i = 0; i < stickNum; i++)  
            scanf("%d%d", &st[i].length, &st[i].weight);  
        sort(st, st + stickNum, cmp);  
        int minTime = 0;  
        int leftAmount = stickNum;  
        while (leftAmount)  
        {  
            minTime++;  
            int lastLength = -1, lastWeight = -1;  
            for (int i = 0; i < stickNum ; i++)  
                if (st[i].deleted == false&&larger(st[i], lastLength, lastWeight))  
                {  
                    st[i].deleted = true;  
                    lastLength = st[i].length;  
                    lastWeight = st[i].weight;  
                    leftAmount--;  
                }  
        }  
        printf("%d\n", minTime);  
    }  
    return 0;  
} 

发布了70 篇原创文章 · 获赞 17 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/hwj_wayne/article/details/50849004