HDU-2095 find your present (异或运算)

                                     find your present (2)

                           Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                Total Submission(s): 28873    Accepted Submission(s): 11315

Problem Description

In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

Input

The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output

For each case, output an integer in a line, which is the card number of your present.

Sample Input

5

1 1 3 2 2

3

1 2 1

0

Sample Output

3

2

Hint

Hint use scanf to avoid Time Limit Exceeded

Author

8600

Source

HDU 2007-Spring Programming Contest - Warm Up (1)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2095

题意:

给你1个n,然后下一行有n个数,问你这些数中哪个出现的次数是奇数次(只有1组),输出它。

思路:

上来就暴力了, 直接开数组,结果内存暴了。

直接用异或运算即可。因为两个相同的数异或的值为0。因为只有一组是奇数个。所以两两抵消,最后就剩下那一个奇数次的数了。

异或的运算法则:

1、a^b = b^a

2、(a^b)^c = a^(b^c)

3、a^b^a = b

异或的两个性质

1、0^n = n

2、n^n = 0

代码:

#include<bits/stdc++.h>
using namespace std;

int main()
{
	int n;
	while(cin >> n) {
		if(n == 0)break;
		int ans =  0;
		while(n--) {
			int t;
			scanf("%d", &t);
			ans ^= t;
		}
		cout << ans << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Sclong0218/article/details/83384764