hdu 6324 Grab The Tree(思维+异或运算)

【题目】

Problem F. Grab The Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 668    Accepted Submission(s): 450


 

Problem Description

Little Q and Little T are playing a game on a tree. There are n vertices on the tree, labeled by 1,2,...,n , connected by n−1 bidirectional edges. The i -th vertex has the value of wi .
In this game, Little Q needs to grab some vertices on the tree. He can select any number of vertices to grab, but he is not allowed to grab both vertices that are adjacent on the tree. That is, if there is an edge between x and y , he can't grab both x and y . After Q's move, Little T will grab all of the rest vertices. So when the game finishes, every vertex will be occupied by either Q or T.
The final score of each player is the bitwise XOR sum of his choosen vertices' value. The one who has the higher score will win the game. It is also possible for the game to end in a draw. Assume they all will play optimally, please write a program to predict the result.

 

Input

The first line of the input contains an integer T(1≤T≤20) , denoting the number of test cases.
In each test case, there is one integer n(1≤n≤100000) in the first line, denoting the number of vertices.
In the next line, there are n integers w1,w2,...,wn(1≤wi≤109) , denoting the value of each vertex.
For the next n−1 lines, each line contains two integers u and v , denoting a bidirectional edge between vertex u and v .

 

Output

For each test case, print a single line containing a word, denoting the result. If Q wins, please print Q. If T wins, please print T. And if the game ends in a draw, please print D.

 

Sample Input

1

3

2 2 2

1 2

1 3

Sample Output

Q

【题解】

题意:给定n个节点的权值与n-1条边,要求先手Q只能取不相邻的点,剩下的点归D,谁选取的点的权值异或和最大谁获胜。

思路:我们可以把所有的点分成两个点集,如果这两个点集异或和相等,就是后手赢,否则先手赢。又因为异或的性质a^a=0,所以全部的权值异或最终结果为0就是后手赢,否则先手赢。

【代码】

#include<stdio.h>
main()
{
    int a[100010];
    int t,n; scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        int x,y;
        for(int i=1;i<n;i++)
            scanf("%d%d",&x,&y);
        int ans=a[1];
        for(int i=2;i<=n;i++)
            ans^=a[i];
        if(ans==0) printf("D\n");
        else printf("Q\n");
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41117236/article/details/81390494
今日推荐