【STL】Find Your Present

描述

In the new year party, everybody will get a “special present”.Now it’s your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present’s card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

输入

The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

输出

For each case, output an integer in a line, which is the card number of your present.

样例输入

5
1 1 3 2 2
3
1 2 1
0

样例输出

3
2

提示

Use scanf to avoid Time Limit Exceeded

分析:
1、统计只出现过一次的数字。
2、用map不是很完美地过关了。
代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
int n;
map<int,int> m;
map<int,int>::iterator it;//迭代器
while(~scanf("%d",&n)&&n)
{
m.clear();//清空
int N;
for (int i=0;i<n;i++)
{
scanf("%d",&N);
m[N]++;
}
for (it=m.begin();it!=m.end();it++)
{
if (it->second==1)//当前元素的值为1,含义为只出现过一次。
{
printf("%d\n",it->first);//输出下标
break;
}
}
}
return 0;
}

发布了122 篇原创文章 · 获赞 0 · 访问量 4668

猜你喜欢

转载自blog.csdn.net/Skynamer/article/details/104143662