HDU 2095 find your present (2)

http://acm.hdu.edu.cn/showproblem.php?pid=2095

Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 
Input
The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 
Output
For each case, output an integer in a line, which is the card number of your present.
 
Sample Input
5
1 1 3 2 2
3
1 2 1
0
 
Sample Output
3
2
 
代码:
#include <bits/stdc++.h>
using namespace std;

int a[1000001];

int main() {
    int n;
    while(~scanf("%d", &n)) {
        if(n == 0) break ;
        int out = 0;
        for(int i = 1; i <= n; i ++) {
            scanf("%d", &a[i]);
            out ^= a[i];
        }
        printf("%d\n", out);
    }
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/9380164.html