HDU-2095 find your present (2)(异或)

Problem Description

In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

Input

The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output

For each case, output an integer in a line, which is the card number of your present.

Sample Input

5

1 1 3 2 2

3

1 2 1

0

Sample Output

3

2

题目大意:给你n个数字,已知只有一个数字出现了奇数次,其他数字都出现了偶数次,要求你找出这个特别的数字。

解题思路:把所有数都做异或运算,结果一定是出现奇数的那个数。因为出现偶数次的数,做异或后为0.

代码:

#include <stdio.h>
int main()
{
	int n,i,a,b;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
			break;
		a=0;
		for(i=0;i<n;i++)
		{
			scanf("%d",&b);
			a=a^b;
		}
		printf("%d\n",a);
	}
}
 

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/82082671