hdu1563-----Find your present!

Problem Description

In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

Input

The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output

For each case, output an integer in a line, which is the card number of your present.

Sample Input

5

1 1 3 2 2

3

1 2 1

0

Sample Output

3

2

题意:输入一串数,找出其中与其他数不同的数并输出。

输入:先输入一个数字n,表示需要输入的个数,当n为0的时候结束

输出:输出其中不同于其他数的数:

算法:采用暴力查找,当找到,break,未找到,就继续查找,其中主要代码如下:

for(i=0;i<n;i++)
{
     for(j=0;j<n;j++)
     {
    	  if(j==i)
             continue;
    	   if(arr[i]==arr[j])
              break;
     }
      if(j==n)
          break;
}

第一个代表查找的次数,共有n个,第二个循环代表与所有的元素相比较,若没有找到相等的,j=n,代表当前a[i]是特殊的数,直接break,输出当前a[i].

全部代码如下:

#include<stdio.h>
int arr[210];
int main()
{
    int n;
    int i,j;
    while(scanf("%d",&n),n)
    {
        for(i=0;i<n;i++)
        	scanf("%d",&arr[i]);
    	for(i=0;i<n;i++)
    	{
    	    for(j=0;j<n;j++)
    	    {
    	        if(j==i)
                    continue;
    	        if(arr[i]==arr[j])
                    break;
    	    }
         	if(j==n)
                break;
    	}
     	printf("%d\n",arr[i]);
    }
    return 0;

}

猜你喜欢

转载自blog.csdn.net/Mldlhd2018/article/details/83958285