第六章树和二叉树--树和森林-计算机17级 7-2 家谱处理 (30 分)

版权声明:欢迎转载,但转载时请注明原文地址 https://blog.csdn.net/weixin_42110638/article/details/83865634

7-2 家谱处理 (30 分)

人类学研究对于家族很感兴趣,于是研究人员搜集了一些家族的家谱进行研究。实验中,使用计算机处理家谱。为了实现这个目的,研究人员将家谱转换为文本文件。下面为家谱文本文件的实例:

John
  Robert
    Frank
    Andrew
  Nancy
    David

家谱文本文件中,每一行包含一个人的名字。第一行中的名字是这个家族最早的祖先。家谱仅包含最早祖先的后代,而他们的丈夫或妻子不出现在家谱中。每个人的子女比父母多缩进2个空格。以上述家谱文本文件为例,John这个家族最早的祖先,他有两个子女RobertNancyRobert有两个子女FrankAndrewNancy只有一个子女David

在实验中,研究人员还收集了家庭文件,并提取了家谱中有关两个人关系的陈述语句。下面为家谱中关系的陈述语句实例:

John is the parent of Robert
Robert is a sibling of Nancy
David is a descendant of Robert

研究人员需要判断每个陈述语句是真还是假,请编写程序帮助研究人员判断。

输入格式:

输入首先给出2个正整数N(2≤N≤100)和M(≤100),其中N为家谱中名字的数量,M为家谱中陈述语句的数量,输入的每行不超过70个字符。

名字的字符串由不超过10个英文字母组成。在家谱中的第一行给出的名字前没有缩进空格。家谱中的其他名字至少缩进2个空格,即他们是家谱中最早祖先(第一行给出的名字)的后代,且如果家谱中一个名字前缩进k个空格,则下一行中名字至多缩进k+2个空格。

在一个家谱中同样的名字不会出现两次,且家谱中没有出现的名字不会出现在陈述语句中。每句陈述语句格式如下,其中XY为家谱中的不同名字:

X is a child of Y
X is the parent of Y
X is a sibling of Y
X is a descendant of Y
X is an ancestor of Y

输出格式:

对于测试用例中的每句陈述语句,在一行中输出True,如果陈述为真,或False,如果陈述为假。

输入样例:

6 5
John
  Robert
    Frank
    Andrew
  Nancy
    David
Robert is a child of John
Robert is an ancestor of Andrew
Robert is a sibling of Nancy
Nancy is the parent of Frank
John is a descendant of Andrew

输出样例:

True
True
True
False
False

借鉴别人的思路: 

给每个人编id号, 用值表示每个对应的id 
用fa[maxn]存的是每个人的父亲id, fa[id] = 父亲的id 

扫描二维码关注公众号,回复: 4034562 查看本文章

实现代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <sstream>
#include <map>
#define mst(a) memset(a,0,sizeof(a));

using namespace std;

/*
parent      (直系)父
child       (直系)孩子
ancestor    祖先
sibling     同辈
descendant  后裔
*/
const int maxn = 100 + 5;
string s;
map<string, int> maps;
int a[maxn], fa[maxn];
vector<int> vec[maxn];

bool dfs(int a, int b)
{
    if( vec[a].size() == 0 )
        return false;
    for( size_t i = 0; i < vec[a].size(); i++ )
    {
        if( vec[a][i] == b )
            return true;
        if( dfs(vec[a][i],b) )
            return true;
    }
    return false;
}

bool solve( string stra, string strb, char ch )
{
    int a = maps[stra], b = maps[strb];
    switch(ch)
    {
    case 'p' :
        return a == fa[b];
        break;
    case 'c' :
        return fa[a] == b;
        break;
    case 'a' :
        return dfs(a, b);
        break;
    case 's' :
        return fa[a] == fa[b];
        break;
    case 'd' :
        return dfs(b, a);
        break;
    }
}

int main()
{
//    ios::sync_with_stdio(false);  //关IO同步就WA?
//    cin.tie(0);
    int n, test, cnt = 0;
    cin >> n >> test;
    getchar();
    while( n-- )
    {
        string name = "";
        s = "";
        getline(cin, s);
        int len = (int)s.size();
        int k = 0;
        for( int i = 0; i < len; i++ )
        {
            if( s[i] != ' ' )
                name += s[i];
            else
                k++;
        }
        k /= 2;
        maps[name] = cnt++;
        int id = maps[name];
        if( k != 0 )  //如果不是最大的祖先
        {
            vec[a[k]].push_back(id);
            fa[id] = a[k];
        }
        else
            fa[id] = -1; //最大祖先没有father
        a[k+1] = id; //更新当前层数的father
    }

    while( test-- )
    {
        string n1, n2, n3, temp;
        cin >> n1 >> temp >> temp >> n2 >> temp >> n3;
        if( solve(n1,n3,n2[0]) )
            cout << "True" << endl;
        else
            cout << "False" << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42110638/article/details/83865634
今日推荐