7-2 家谱处理 (30 分)

版权声明:沃斯里德小浩浩啊 https://blog.csdn.net/Healer66/article/details/83791622

7-2 家谱处理 (30 分)

人类学研究对于家族很感兴趣,于是研究人员搜集了一些家族的家谱进行研究。实验中,使用计算机处理家谱。为了实现这个目的,研究人员将家谱转换为文本文件。下面为家谱文本文件的实例:

John
  Robert
    Frank
    Andrew
  Nancy
    David

家谱文本文件中,每一行包含一个人的名字。第一行中的名字是这个家族最早的祖先。家谱仅包含最早祖先的后代,而他们的丈夫或妻子不出现在家谱中。每个人的子女比父母多缩进2个空格。以上述家谱文本文件为例,John这个家族最早的祖先,他有两个子女RobertNancyRobert有两个子女FrankAndrewNancy只有一个子女David

在实验中,研究人员还收集了家庭文件,并提取了家谱中有关两个人关系的陈述语句。下面为家谱中关系的陈述语句实例:

John is the parent of Robert
Robert is a sibling of Nancy
David is a descendant of Robert

研究人员需要判断每个陈述语句是真还是假,请编写程序帮助研究人员判断。

输入格式:

输入首先给出2个正整数N(2≤N≤100)和M(≤100),其中N为家谱中名字的数量,M为家谱中陈述语句的数量,输入的每行不超过70个字符。

名字的字符串由不超过10个英文字母组成。在家谱中的第一行给出的名字前没有缩进空格。家谱中的其他名字至少缩进2个空格,即他们是家谱中最早祖先(第一行给出的名字)的后代,且如果家谱中一个名字前缩进k个空格,则下一行中名字至多缩进k+2个空格。

在一个家谱中同样的名字不会出现两次,且家谱中没有出现的名字不会出现在陈述语句中。每句陈述语句格式如下,其中XY为家谱中的不同名字:

X is a child of Y
X is the parent of Y
X is a sibling of Y
X is a descendant of Y
X is an ancestor of Y

输出格式:

对于测试用例中的每句陈述语句,在一行中输出True,如果陈述为真,或False,如果陈述为假。

输入样例:

6 5
John
  Robert
    Frank
    Andrew
  Nancy
    David
Robert is a child of John
Robert is an ancestor of Andrew
Robert is a sibling of Nancy
Nancy is the parent of Frank
John is a descendant of Andrew

输出样例:

True
True
True
False
False
#include <bits/stdc++.h>
#include <cstdio>
using namespace std;

int M,N,cnt = 0;
struct node
{
    char name[15];
    int num;
    struct node * father;
} Node[110];
typedef struct node node;
struct Question
{
    char namea[15],nameb[15],relation[20];
} Ques[110];
void Input()
{
    string name;
    cin>>N>>M;
    getchar();
    for(int i = 0; i < N; i++)
    {
        Node[i].num = 0;
        getline(cin,name);
        //gets(name);
        int len = name.size();
        for(int j = 0; j < len; j++)
        {
            if(name[j] == ' ')
                Node[i].num++;
            else
            {
                strcpy(Node[i].name,name.substr(j,len-j+1).c_str());
                break;
            }
        }
        if(Node[i].num == 0)
        {
            Node[i].father = NULL;
        }
        else
        {
            for(int k = i - 1; k >=0; k--)
            {
                if(Node[i].num > Node[k].num)
                {
                    Node[i].father  = Node + k;
                    break;
                }
            }
        }
    }
    for(int i = 0; i < M; ++i)
    {
        cin>>Ques[i].namea>> name>> name>> Ques[i].relation>>name>> Ques[i].nameb;
    }
}
node * getP(char name[])
{
    for(int i = 0; i < N ; i++)
        if(strcmp(name,Node[i].name) == 0)
            return Node + i;
}
void isChild(node *a, node *b)
{
    if(a->father)
    {
        if(strcmp(a->father->name,b->name) == 0)
            cout<<"True"<<endl;
        else
            cout<<"False"<<endl;
    }
    else
    {
        cout<<"False"<<endl;
    }
}
void isParent(node *a, node *b)
{
    if(b->father)
    {
        if(strcmp(b->father->name,a->name) == 0)
            cout<<"True"<<endl;
        else
            cout<<"False"<<endl;
    }
    else
    {
        cout<<"False"<<endl;
    }
}
void isSibling(node *a, node *b)
{
    if(b->father && a->father)
    {
        if(strcmp(a->father->name,b->father->name) == 0)
        {
            cout<<"True"<<endl;
        }
        else
            cout<<"False"<<endl;
    }
    else
        cout<<"False"<<endl;
}

void isDescendant(node *a,node *b)
{
    node *t = a->father;
    while(t)
    {
        if(strcmp(t->name,b->name) == 0)
        {
            cout<<"True"<<endl;
            return ;
        }
        else
            t = t->father;
    }
    cout<<"False"<<endl;
}
void isAncestor(node *a, node *b)
{
    node *t = b->father;
    while(t)
    {
        if(strcmp(t->name,a->name) == 0)
        {
            cout<<"True"<<endl;
            return;
        }
        else
            t = t->father;
    }
    cout<<"False"<<endl;
}
void Solve()
{
    for(int i = 0; i  < M; i++)
    {
        // cout<<i<<endl;
        node *A,*B;
        A = getP(Ques[i].namea);
        B = getP(Ques[i].nameb);
        if(strcmp(Ques[i].relation,"child") == 0)
        {
            isChild(A,B);
        }
        if(strcmp(Ques[i].relation,"parent") == 0)
        {
            isParent(A,B);
        }
        if(strcmp(Ques[i].relation,"sibling") == 0)
        {
            isSibling(A,B);
        }
        if(strcmp(Ques[i].relation,"descendant") == 0)
        {
            isDescendant(A,B);
        }
        if(strcmp(Ques[i].relation,"ancestor") == 0)
        {
            isAncestor(A,B);
        }
    }
}
int main()
{
    Input();
    Solve();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Healer66/article/details/83791622