7-3 家谱处理 (30 分)

7-3 家谱处理 (30 分)

人类学研究对于家族很感兴趣,于是研究人员搜集了一些家族的家谱进行研究。实验中,使用计算机处理家谱。为了实现这个目的,研究人员将家谱转换为文本文件。下面为家谱文本文件的实例:

John
  Robert
    Frank
    Andrew
  Nancy
    David

家谱文本文件中,每一行包含一个人的名字。第一行中的名字是这个家族最早的祖先。家谱仅包含最早祖先的后代,而他们的丈夫或妻子不出现在家谱中。每个人的子女比父母多缩进2个空格。以上述家谱文本文件为例,John这个家族最早的祖先,他有两个子女RobertNancyRobert有两个子女FrankAndrewNancy只有一个子女David

在实验中,研究人员还收集了家庭文件,并提取了家谱中有关两个人关系的陈述语句。下面为家谱中关系的陈述语句实例:

John is the parent of Robert
Robert is a sibling of Nancy
David is a descendant of Robert

研究人员需要判断每个陈述语句是真还是假,请编写程序帮助研究人员判断。

输入格式:

输入首先给出2个正整数N(2≤N≤100)和M(≤100),其中N为家谱中名字的数量,M为家谱中陈述语句的数量,输入的每行不超过70个字符。

名字的字符串由不超过10个英文字母组成。在家谱中的第一行给出的名字前没有缩进空格。家谱中的其他名字至少缩进2个空格,即他们是家谱中最早祖先(第一行给出的名字)的后代,且如果家谱中一个名字前缩进k个空格,则下一行中名字至多缩进k+2个空格。

在一个家谱中同样的名字不会出现两次,且家谱中没有出现的名字不会出现在陈述语句中。每句陈述语句格式如下,其中XY为家谱中的不同名字:

X is a child of Y
X is the parent of Y
X is a sibling of Y
X is a descendant of Y
X is an ancestor of Y

输出格式:

对于测试用例中的每句陈述语句,在一行中输出True,如果陈述为真,或False,如果陈述为假。

输入样例:

6 5
John
  Robert
    Frank
    Andrew
  Nancy
    David
Robert is a child of John
Robert is an ancestor of Andrew
Robert is a sibling of Nancy
Nancy is the parent of Frank
John is a descendant of Andrew

输出样例:

True
True
True
False
False
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <map>
#include <set>
#include <vector>
#include <cstring>
#include <queue>
#include <cmath>
#define FRER() freopen("in.txt","r",stdin);
#define FREW() freopen("out.txt","w",stdout);
#define mem(a,b) memset(a,b,sizeof(a));
#define go int T;scanf("%d",&T);for(int cas=1;cas<=T;cas++)
#define mod 1000000007
using namespace std;
typedef pair<int,int> pii;
typedef long long ll;
map<string,string>mmp;
string s[70];
int cal_space(string str){
    int cnt = 0;
    while(str[cnt++]==' ');
    return cnt;
}
bool ok(string s1,string s2){
    while(mmp[s1]!=s2&&mmp[s1]!="qp"){
        s1=mmp[s1];
    }
    if(mmp[s1]==s2) return true;
    return false;
    
}
int main(){
    //FRER();
    int n,m;
    scanf("%d%d",&n,&m);
    getchar();
    for(int i=0;i<n;i++){
        string str;
        getline(cin, str);
        int cnt = cal_space(str)-1;
        if(cnt==0) {mmp[str] = "qp";s[0] = str;}
        else{
            string ss;
            for(int i=cnt;i<str.size();i++){
                ss+=str[i];
            }
            s[cnt] = ss;
            mmp[ss] = s[cnt-2];
        }
    }
    while(m--){
        string str,s1,s2,s3;
        getline(cin, str);
        for(int i=0;i<str.size();i++){
            if(str[i]==' ') break;
            s1+=str[i];
        }
        for(int i=(int)str.size()-1;i>=0;i--){
            if(str[i]==' ') break;
            s3+=str[i];
        }
        for(int i=(int)s3.size()-1;i>=0;i--){
            s2+=s3[i];
        }
        if(str.find("child")!=-1){
            printf("%s\n",mmp[s1]==s2?"True":"False");
        }
        else if(str.find("parent")!=-1){
            printf("%s\n",mmp[s2]==s1?"True":"False");
        }
        else if(str.find("descendant")!=-1){
            printf("%s\n",ok(s1,s2)?"True":"False");
        }
        else if(str.find("ancestor")!=-1){
            printf("%s\n",ok(s2,s1)?"True":"False");
        }
        else{
            printf("%s\n",mmp[s1]==mmp[s2]?"True":"False");
        }
    }
}

猜你喜欢

转载自blog.csdn.net/Insist_77/article/details/83794295
今日推荐