二分贪心专题E

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in theith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input
6
A
C
D
B
C
B

Sample Output

ABCBCD
每次从两头选字母 不一样时选小的 一样时往里找第一次出现不一样选小的 注意一下特殊情况如AABB这类的

源代码:

#include<iostream>
#include<string.h>
using namespace std;

int main()
{
	int n,tot=0;
	char a[2222];
	cin>>n;
	for (int i=1;i<=n;i++) cin>>a[i];
	int head=1,tail=n;char s[2222];
	while (head<=tail)
	{
		if (a[head]<a[tail]) s[++tot]=a[head++];
		if (a[head]>a[tail]) s[++tot]=a[tail--];
		if (a[head]==a[tail])
		{
			int l=head,r=tail;
			while (a[l]==a[r]&&l!=r)
			{
				l++;r--;
			}
			if (a[l]<a[r]) s[++tot]=a[head++];
			if (a[r]<a[l]) s[++tot]=a[tail--];
			if (r==l) s[++tot]=a[tail--]; 
			if (l>r) s[++tot]=a[tail--]; 
		}
	}
	if (tot!=n) 
	{
		s[++tot]=a[head];
	}
	for (int i=1;i<=tot;i++)
	{
		cout<<s[i];if (i%80==0) cout<<endl;
	}
	return 0;
} 


猜你喜欢

转载自blog.csdn.net/ruozhalqy/article/details/54781426