二分贪心专题B

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2). 
InputThe input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces. 
OutputThe output should contain the minimum setup time in minutes, one per line. 
Sample Input
3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2

1

3

题目大意:有一堆待加工的木棒,木棒有属性长度L和质量W,我们对木棒加工有准备时间,规则如下:

1.第一根木棒花费准备时间1min

2.加工长度与质量均比上一根大的不需要准备时间,反之需要花费1min

要求求最小的准备时间。

按照题意分析,我们将L与W看做两个数列,两个数列递增则不需要准备时间。即有几个这样双递增的数列就需要花费几分钟准备时间。

首先我们先找一个单递增的数列(L或者W) 这里我们以L为关键字进行排序。L相同的情况下按照W从小到大排序。

现在L已经是单调递增数列。我们从头遍历,找有几个单增的W数列(方法很简单就是有一个变量记录上一个木棒的W属性,对于当前访问的木棒i,若Wi<W,则是一个新的数列,否则continue)。添加标记数组v,已加工的木棒标为true。 


源代码:

#include<iostream>
#include<algorithm>
using namespace std;

struct mytype
{
	int length;
	int weight;
	bool vis;
};

int mycompare(mytype a,mytype b)
{
	if (a.length==b.length) return a.weight<b.weight;
	return a.length<b.length;
}

int main()
{
	int k;
	cin>>k;
	for (int o=1;o<=k;o++)
	{
		int n;
		mytype a[5010];
		cin>>n;
		for (int i=1;i<=n;i++) a[i].vis=false;
		for (int i=1;i<=n;i++) cin>>a[i].length>>a[i].weight;
		sort(a+1,a+n+1,mycompare);
		int ans=0;int wei;
		for (int i=1;i<=n;i++)
		{
			if (a[i].vis) continue;
			if (!a[i].vis)
			{
				ans++;
				a[i].vis=true;
				wei=a[i].weight;
			}
			for (int j=i+1;j<=n;j++)
			{
				if (a[j].vis) continue;
				if (!a[j].vis&&a[j].weight<wei) continue;
				if (!a[j].vis&&a[j].weight>=wei)
				{
					a[j].vis=true;
					wei=a[j].weight;
					continue;
				}
			}
		}
		cout<<ans<<endl;	
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/ruozhalqy/article/details/54630410