(3)E - 二分

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input
sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5
Sample Output
 
 

sample output #1 3 sample output #2 2


题意:有n件衣服,每件衣服有ai单位的水,每分钟可以自然脱干1单位,也可以用脱干机脱干,脱干机脱干时,不算自然脱干,求所有衣服需要最小时间,我以为用贪心,,后来才知道是用二分法。可以推导出公式,不过我不会,设自然晾干为x1,脱干为x2,则有mid=x1+x2,ai<=k*x1+x2,得x1>=(ai-mid)/(k-1);好像都是这套路

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;
long long a[100010];
long long k;
int n;
bool find(long long m);
int main()
{
 long long max,mid,left,right;
 int i,j;
 while((scanf("%lld",&n)!=EOF))
 {
  max=0;
  for(i=0;i<n;i++)
  {
   scanf("%lld",&a[i]);
   if(max<a[i])
   {
    max=a[i]; 
   }  
  }
  cin>>k;
  left=0,right=max;
  while(left<right-1)
  {
   mid=(left+right)/2;
   if(find(mid))
   {
    left=mid;
   }
   else
   {
    right=mid;
   }
  }
  printf("%lld",right);
 } 
}
bool find(long long m)
{
 int i;
 long long temp=0;
 if(k==1)
 {
  return 1;
 }
 for(i=0;i<n;i++)
 {
  if(a[i]>m)
  {
   temp+=(a[i]-m+k-2)/(k-1);
  }
 }
 if(temp>m)
 {
  return 1;
 }
 else
 {
  return 0;
 }
}

猜你喜欢

转载自blog.csdn.net/whhhzs/article/details/79392952