HDU - 1517 - A Multiplication Game

Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
Input
Each line of input contains one integer number n.
Output
For each line of input output one line either
Stan wins.
or
Ollie wins.
assuming that both of them play perfectly.
Sample Input
162
17
34012226
Sample Output
Stan wins.
Ollie wins.
Stan wins.
题目链接
参考题解

这个题目是一个神奇的博弈论问题,具体的话我也不太明白,所以写一篇记录一下。主要应该是巴什博奕的变异问题,还是要找一下规律。
AC题解:

#include <cstdio>
using namespace std;

int main()
{
    double n;
    while(~scanf("%lf", &n))
    {
        while(n > 18)   n /= 18;
        printf(n <= 9 ? "Stan wins.\n" : "Ollie wins.\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40788897/article/details/82912601