1054 求平均值 (sscanf(), sprintf()处理字符串)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/LightInDarkness/article/details/83023796

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y

输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:

2
aaa -9999

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

       说真的,这个题让我非常困扰。我的思路是不合法的数据有太多种类型了,那我就去判断合法的数据。题干描述太过于简洁,到底什么才是合法的数据,并没有给出详细说明。我个人的代码总是有一个测试点过不了,后来去看别人的博客,我发现就算是提交到PTA正确的代码,对于同一个其他的样例,也会有不同的结果。索性学习了小姐姐的代码,十分佩服。

#include<iostream>
#include<cstdio>
#include<string.h>

using namespace std;

int main(){
	int n, cnt = 0;
	char a[50], b[50];
	double temp, sum = 0.0;
	cin >> n;
	for(int i = 0; i < n; i++){
		scanf("%s", a);
		sscanf(a, "%lf", &temp);
		sprintf(b, "%.2lf", temp);
		int flag = 0;
		for(int j = 0; j < strlen(a); j++){
			if(a[j] != b[j]) flag = 1;
		}
		if(flag || temp < -1000 || temp > 1000){
			printf("ERROR: %s is not a legal number\n", a);
            continue;
		}else{
			sum += temp;
			cnt++;
		}
	}
	if(cnt == 1) {
        printf("The average of 1 number is %.2lf", sum);
    }else if(cnt > 1) {
        printf("The average of %d numbers is %.2lf", cnt, sum / cnt);
    }else {
        printf("The average of 0 numbers is Undefined");
    }
}

sscanf():从一个字符串中读入指定格式的数据。

sprintf():字符串格式化命令,主要功能是把格式化的数据写入某个字符串中。

猜你喜欢

转载自blog.csdn.net/LightInDarkness/article/details/83023796