PAT乙级真题 1054 求平均值 C++实现(附sstream判断字符串是否为数字的方法,测试点2有坑)

题目

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。
输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例 2:
2
aaa -9999
输出样例 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

思路

关键是如何判断一个字符串是否为数字,用到了sstream.h。
sstream.h定义了三个类:istringstream、ostringstream 和 stringstream,分别用来进行字符串流的输入、输出和输入输出操作。将一个字符串作为输入源,向某个类型的变量中输入,如果输入失败则返回false。

判断字符串是否为数字类型:

bool isNumber(string s){
    istringstream sin(s);
    double test;
    return sin >> test && sin.eof();
}

测试点2的坑:题目中要求如果 K 为 1,则输出 The average of 1 number is Y,不是numbers了!!!审题一定要逐字逐句。

扩展知识

sstream可以用来分割字符串。

提取一段文字中单词的例子:

#include<iostream>  
#include<sstream>
using namespace std;  
int main()  
{      
    string str="i am a boy";      
    istringstream is(str);     
    string s;      
    while(is>>s)      
         cout<<s<<endl;          
}

按照某个字符切割字符串的例子:

#include <iostream>
#include <sstream>
using namespace std;
int main() {
    string str = "arg1&arg2&arg3";
    istringstream ss(str);
    string temp;
    while (getline(ss, temp, '&')) {
        cout << temp << endl;
    }
    return 0;
}

getline从is中提取字符串存储到str中,直到遇到限界符delim(或换行符’\n’,对于第(2)种用法):

(1)	
istream& getline (istream&  is, string& str, char delim);
istream& getline (istream&& is, string& str, char delim);
(2)	
istream& getline (istream&  is, string& str);
istream& getline (istream&& is, string& str);

代码

#include <iostream>
#include <sstream>
#include <iomanip>
using namespace std;

bool isNumber(string s){
    istringstream sin(s);
    double test;
    return sin >> test && sin.eof();
}

int main(){
    int n;
    cin >> n;
    string str;
    double sum = 0;
    int count = 0;
    for (int i=0; i<n; i++){
        bool islegal = true;
        cin >> str;
        double d = 0;
        if (isNumber(str)){
            d = stod(str);
            if (d<-1000 || d>1000){
                islegal = false;
            }
            else{
                int pos = str.find('.');
                if (pos!=string::npos && str.length()-3>pos){
                    islegal = false; 
                }
            }
        }
        else{
            islegal = false;
        }

        if (islegal){
            count++;
            sum += d;
        }
        else {
            cout << "ERROR: " << str << " is not a legal number" << endl;
        }
    }

    if (count==0){
        cout << "The average of 0 numbers is Undefined" << endl;
    }
    else if (count==1){
        cout << "The average of 1 number is " << fixed << setprecision(2) << sum << endl;
    }
    else{
        cout << "The average of " << count << " numbers is " << fixed << setprecision(2) << sum / count << endl;
    }
    return 0;
}


发布了105 篇原创文章 · 获赞 7 · 访问量 1744

猜你喜欢

转载自blog.csdn.net/zhang35/article/details/103882382