pat 1054 求平均值 (20)

1054 求平均值 (20)(20 分)

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例2:

2
aaa -9999

输出样例2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

对这种输出形式要求很高的题目,应该将各种格式阐述清楚,否则真的很难调试
下面的代码只是我自己写的,并不完全正确
#include <iostream> 
#include <sstream>
#include <string>
#include<iomanip>
using namespace std;

int num=0;	
double sum=0;

//该字符串是否包含除 - . 0-9以外的字符 
int containCh(string str) 
{
	int i,len=str.size();
	for(i=0;i<len;i++)
	{
		if(str[i]=='-'||str[i]=='.')
		{
			continue;
		}
		if(str[i]<'0'||str[i]>'9')
		{
			return 1;
		}
	}
	return 0;
}

//
//将字符串转化为整数
int stoint(string res)
{
	int a;
    stringstream ss;  
    ss << res;                  
    ss >> a;
    return a;
} 

//将字符串转化为浮点数 
double stodouble(string res)
{
	double a;
    stringstream ss;  
    ss << res;                  
    ss >> a;
    return a;
} 

//当字符串只包含合法的字符时对字符串进行判断 
void pointnum(string str)
{
	int i,len=str.size();
	//统计小数点的个数 
	int count=0;
	for(i=0;i<len;i++)
	{
		if(str[i]=='.')
		{
			count++; 
		}
	}
	//当没有小数点时 
	if(count==0)
	{
		int a=stoint(str);
		if(a>=-1000&&a<=1000)
		{
			sum+=a;
			num++;
		}
		else
		{
			cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
		}
	}
	else if(count==1)
	{
		int pos=str.find('.');
		//小数点后的位数<=2位 
		if(len-pos-1<=2)
		{
			double b=stodouble(str);
			sum+=b;
			num++;
		}
		else
		{
			cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
		}
	}
	else if(count>1)
	{
		cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
	}
} 

int main()
{
	int n,i;
	cin>>n;
	string *input=new string[n];
	for(i=0;i<n;i++)
	{
		cin>>input[i];
	}
	for(i=0;i<n;i++)
	{
		//如果该字符串包含不合法的字符直接跳过 
		if(containCh(input[i]))
		{
			cout<<"ERROR: "<<input[i]<<" is not a legal number"<<endl;
		}
		else
		{
			pointnum(input[i]);
		}
	}
	if(num==0)
	{
		cout<<"The average of "<<num<<" numbers is Undefined"<<endl; 
	}
	else
	{
		double average=sum/num;
	    cout<<"The average of "<<num<<" numbers is "<<setiosflags(ios::fixed)<<setprecision(2)<<average;
	}
	return 0;
}

  

 

猜你喜欢

转载自www.cnblogs.com/houchen/p/9253176.html