PAT 1054. 求平均值

本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出“The average of 1 number is Y”。

输入样例1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例2:
2
aaa -9999
输出样例2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number

The average of 0 numbers is Undefined

#include <iostream>
#include <iomanip>
using namespace std;
int main(){
	int N;
	scanf("%d",&N);
	char s[1000];
	float num=0.0;
	int v=0;
	for(int i=0;i<N;i++){
		scanf("%s",&s);
		int p=0;
		bool flag=true;
		int point=0;
		while(s[p]!='\0'){//把小数点多的,负号不在首位的,字符串里有其他字符的刨除掉 
			if(s[p]=='.'){
				point++;
				if(point>1){
					flag=false;
					break;
				}
			}
			if(s[p]=='-'&&p!=0){
				flag=false;
				break;
			}
			if((s[p]<'0'||s[p]>'9')&&s[p]!='.'&&s[p]!='-'){
				flag=false;
				break;
			}
			p++;
		}
		if(flag){ //如果通过了上面的检验,就说明肯定是数据了 
			p=0;
			bool f=true;
			float temp=0.0;
			if(s[p]=='-'){
				f=false;//记录负号,计算的最后再加上 
				p++;
			}
			while(s[p]!='.'&&s[p]!='\0'){//计算小数点前面的整数部分值 
				temp=temp*10+(s[p]-48);
				p++;
			}
			if(s[p]=='.'){//计算小数点后面小数部分的值 
				p++;
				int c=0;
				float b=10;
				while(s[p]!='\0'&&c<=2){
					temp=temp+(s[p]-48)/b;
					b=b*10;
					p++;
					c++;
				}
				if(c>2){//如果小数点后多于两位数,剔除 
					flag=false;
				}
			}
			if(temp>1000){//如果数值大小不在合理区间内,剔除 
				flag=false;
			}
			if(flag){//经检验合法的数据加到总和里 
				v++;//记录合法数据的个数 
				if(f){//求总和时考虑负数的情况 
					num=num+temp;
				}
				else{
					num=num-temp;
				}
			}
		}
		if(!flag){
			printf("%s%s%s\n","ERROR: ",s," is not a legal number");
		}
	}
	if(v==1){
		printf("%s","The average of 1 number is ");
		
		cout<<fixed<<setprecision(2)<<num<<endl;
	}
	else if(v>1){
		printf("%s%d%s","The average of ",v," numbers is ");
		
		cout<<fixed<<setprecision(2)<<num/v<<endl;
	}
	else{
		printf("%s%d%s\n","The average of ",v," numbers is Undefined");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiao_chen_l/article/details/80056534
今日推荐