1054 求平均值 (20分)

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。

输入格式:

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y

输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:

2
aaa -9999

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
#include <iostream>
#include <string>
#include <algorithm>
#include <cmath>
#include <bits/stdc++.h>

using namespace std;

// 必须是数字或小数点
bool isDigitOrPoint(string s){
    int len = s.length();
    for (int i = 1; i < len; i++)
        if (s[i]!='.' && !isdigit(s[i]))
            return false;
    return true;
}

// string转double
double stringToDouble(string s){
    char r[1000];
    int len = s.length();
    for (int i = 0; i < len; i++)
        r[i] = s[i];
    r[len] = '\0';
    return atof(r); // 返回double
}

// 判断字符串是否合法
bool isValid(string s){
    if (count(s.begin(), s.end(), '.') > 1) // 小数点个数
        return false;
    int lenDecimal = 0;
    if (s.find('.') != string::npos) // 小数位数
        lenDecimal = s.length() - s.find('.') - 1;
    if (!(s[0]=='-' && s.length()>1) && !isdigit(s[0])) // !(负数 && 正数)
        return false;
    if (lenDecimal<=2  // 小数位数不超过2
        && abs(stringToDouble(s))<=1000 // 数值范围[-1000,1000]
        && isDigitOrPoint(s)) // 须是数字或小数点
        return true;
    return false;
}

int main()
{
    string s;
    int n;
    double sum = 0;
    int valid = 0;
    
    cin >> n;
    while (n--){
        cin >> s;
        if (isValid(s)){ // 合法
            sum += stringToDouble(s);
            valid++;
        } else
            cout << "ERROR: " << s << " is not a legal number" << endl;
    }
    
    if (valid == 0)
        cout << "The average of 0 numbers is Undefined";
    else if (valid == 1) // 注意个数为1时的number是单数
        cout << "The average of 1 number is " << setiosflags(ios::fixed) << setprecision(2) << sum;
    else
        cout << "The average of "<< valid << " numbers is " << setiosflags(ios::fixed) << setprecision(2) << sum/double(valid);
    
    
    return 0;
}
发布了131 篇原创文章 · 获赞 136 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/Aibiabcheng/article/details/104200324