※1054 求平均值 (20 分)

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内

输入格式:

输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。

输出格式:

对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y

输入样例 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

输出样例 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:

2
aaa -9999

输出样例 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

题解:

#include<iostream>
#include<string>
#include<cmath>

using namespace std;
//判断是否是数字
//第一位符号位跳过,碰到小数点跳过
bool isDigit(string s) {
    
    
	int i = s[0] == '-' ? 1 : 0;
	for (; i < s.length(); i++) {
    
    
		if (s[i] == '.') continue;
		if (s[i] < '0' || s[i] > '9') {
    
    
			return false;
		}
	}
	return true;
}
//判断数字是否合法
//第一次碰到小数点推出,判断后面有无小数点或小数点后位数大于2或大于[-1000, 1000]
bool isLegal(string s) {
    
    
	int i;
	for (i = 0; i < s.length(); i++) {
    
    
		if (s[i] == '.') break;
	}
	int cnt = 0;
	for (int j = i + 1; j < s.length(); j++) {
    
    
		if (s[j] == '.') return false;
		cnt++;
	}
	if (cnt > 2) return false;
	if (stod(s) < -1e3 || stod(s) > 1e3) return false;
	return true;
}

int main() {
    
    
	int n, cnt = 0;
	double sum = 0.0;
	string s;
	cin >> n;
	for (int i = 0; i < n; i++) {
    
    
		cin >> s;
		if (isDigit(s) && isLegal(s)) {
    
    
			cnt++;
			sum += stod(s);
		}
		else {
    
    
			cout << "ERROR: " << s << " is not a legal number" << endl;
		}
	}
	if (cnt == 0) {
    
    
		cout << "The average of " << cnt << " numbers is Undefined" << endl;
	}
	else if (cnt == 1){
    
    
		cout << "The average of 1 number is ";
		printf("%.2lf\n", sum);
	}
	else {
    
    
		cout << "The average of " << cnt << " numbers is ";
		printf("%.2lf\n", sum / cnt);
	}

	return 0;
}

注:
stoi() string—>int
stod()string—>double


if (isDigit(s) && isLegal(s))这里isDigit(s)先判断如果结果为false后面 isLegal(s)不会进行


自己犯的错: isLegal函数最后判断数字范围用了stoi函数--->应该用stod函数
比如:
stoi(1000.78) = 1000;
stod(1000.78) = 1000.78;

猜你喜欢

转载自blog.csdn.net/qq_44715943/article/details/114906514