【POJ 2318】TOYS

【题目】

传送门

Description

Calculate the number of toys that land in each bin of a partitioned toy box.

Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.

在这里插入图片描述

For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are “in” the box.

【分析】

大致题意:给出一个箱子,里面有 n n 个隔板,现在给出 m m 个玩具的坐标,问每块区域内玩具的个数

题解:计算几何+二分

其实这道题也不是一道难题,由于题目中说了给出的隔板是有序的,满足单调性,所以我们对于每个玩具,就二分找出它应该刚好在哪一块隔板的左边(或右边都可以),找的时候也比较简单,就直接利用叉积的性质,找到后统计答案即可

注意一下输出格式,其中最后一个询问结束后应只输出一个换行,不能输出两个

【代码】

#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 5005
#define eps 1e-8
using namespace std;
int n,m,x1,y1,x2,y2;
int u[N],l[N],num[N];
struct point
{
	int x,y;
	point(){}
	point(int x,int y):x(x),y(y){}
	point operator+(const point &a)  {return point(x+a.x,y+a.y);}
	point operator-(const point &a)  {return point(x-a.x,y-a.y);}
	point operator*(const int &a)  {return point(x*a,y*a);}
	point operator/(const int &a)  {return point(x/a,y/a);}
	friend int dot(const point &a,const point &b)  {return a.x*b.x+a.y*b.y;}
	friend int cross(const point &a,const point &b)  {return a.x*b.y-a.y*b.x;}
}p;
bool check(int mid)
{
	point a=point(u[mid],y1);
	point b=point(l[mid],y2);
	return cross(a-p,b-p)<=0;
}
int solve()
{
	int l=1,r=n+1;
	while(l<r)
	{
		int mid=(l+r)>>1;
		if(check(mid))  r=mid;
		else  l=mid+1;
	}
	return l-1;
}
int main()
{
	int i,cas=0;
	while(~scanf("%d",&n))
	{
		if(!n)  break;
		scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
		for(i=1;i<=n;++i)
		  scanf("%d%d",&u[i],&l[i]);
		u[n+1]=l[n+1]=x2;
		memset(num,0,sizeof(num));
		for(i=1;i<=m;++i)
		{
			scanf("%d%d",&p.x,&p.y);
			num[solve()]++;
		}
		if(++cas!=1)  printf("\n");
		for(i=0;i<=n;++i)
		  printf("%d: %d\n",i,num[i]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/forever_dreams/article/details/83060709