POJ - 2318 TOYS————计算几何

alculate the number of toys that land in each bin of a partitioned toy box.
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys.

John’s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box.
这里写图片描述
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.
Input
The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.
Output
The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.
Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
Hint
As the example illustrates, toys that fall on the boundary of the box are “in” the box.


题意
有一个矩形盒子,放入n块按照x轴排序的不相交的隔板,这样就将矩形盒子分成了n+1块区域。现在将m个玩具放入这个矩形盒子,统计每个区域的玩具个数。(玩具不会与隔板有重叠部分)
数据解释
第一行6个整数: n(0 < n <= 5000), m (0 < m <= 5000), x1, y1, x2, y2 n代表隔板数目,m是玩具数目,x1,y1是抽屉左上角坐标,x2,y2是抽屉右下角坐标。 接下来n行给出n块板子的顶部x坐标ti,底部x坐标bi。 接下来m行给出m个玩具的坐标xi, yi。
思路
先将线段存起来,在对每个玩具的的坐标与两个相邻的线段短点进行叉乘,若两个叉乘的值一正一负,则说明这个点在这两个线段之间。否则不在,
这里写图片描述
就是这种情况


具体还是看代码吧:

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
typedef long long ll;
const int MAXN=5000+5;
struct node{
    int x,y;
    node(){}
    node(int _x,int _y)
    {
        x=_x;
        y=_y;
    }
}p[MAXN];
struct line{
    node s,e;
    line(){}
    line(node _s,node _e)
    {
        s=_s;
        e=_e;
    }
}l[MAXN];

bool cmp1(node a,node b)
{
    return a.x==b.x?a.y<b.y:a.x<b.x;
}

int dir(node p1,node p2,node p3)//
{
    return (p3.x-p1.x)*(p2.y-p1.y)-(p2.x-p1.x)*(p3.y-p1.y);
}

int main()
{
    int n,m,x1,x2,y1,y2;
    int k=1;
    while(~scanf("%d",&n)&&n)
    {
        if(k)   k=0;
        else    printf("\n");
        int a[MAXN];
        memset(a,0,sizeof(a));
        scanf("%d %d %d %d %d",&m,&x1,&y1,&x2,&y2);
        l[0]=line(node(x1,y1),node(x1,y2));
        for(int i=1;i<=n;i++)
        {
            int x_1,x_2;
            scanf("%d %d",&x_1,&x_2);
            l[i]=line(node(x_1,y1),node(x_2,y2));
        }
        l[n+1]=line(node(x2,y1),node(x2,y2));
        for(int i=0;i<m;i++)
        {
            int x,y;
            scanf("%d %d",&x,&y);
            p[i]=node(x,y);
        }
        sort(p,p+m,cmp1);
        for(int i=0;i<m;i++)
        {
            for(int j=0;j<=n;j++)
            {
                if((dir(p[i],l[j].s,l[j].e)>0&&dir(p[i],l[j+1].s,l[j+1].e)<0)||(dir(p[i],l[j].s,l[j].e)<0&&dir(p[i],l[j+1].s,l[j+1].e)>0))
//              if(dir(p[i],l[j].s,l[j].e) * dir(p[i],l[j+1].s,l[j+1].e)<0)
                {
                    a[j]++;
                    break;
                }
            }
        }
        for(int i=0;i<n+1;i++)
            printf("%d: %d\n",i,a[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Hpuer_Random/article/details/81350417